aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commit21f10c11f39020f9502d741c774a12d1aeb39499 (patch)
treefdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-support/vim
parent723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff)
downloadmeta-openembedded-contrib-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.769.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.769.bb b/meta-oe/recipes-support/vim/vim_7.4.769.bb
index c257d90571..08e5027a8a 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.769.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.769.bb
@@ -32,8 +32,8 @@ do_configure () {
#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
PACKAGECONFIG ??= ""
-PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
-PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
+PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+,"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"