aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorQi Hou <qi.hou@windriver.com>2017-12-04 16:29:57 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-01 07:32:04 -0800
commit846e0098814d45cf4b8ea2625ee824faf519147e (patch)
tree942e2b239834872c249905a43921476fe374934b /meta-oe/recipes-support
parentf48be7e9b19a1e3ec3a03a9a5d9ca7e08a54a7ad (diff)
downloadmeta-openembedded-contrib-846e0098814d45cf4b8ea2625ee824faf519147e.tar.gz
openldap: fix QA Warning
While building openldap, there was a warning, like below: WARNING: QA Issue: openldap: Files/directories were installed but not shipped in any package: /usr/libexec Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. openldap: 1 installed and not shipped files. [installed-vs-shipped] This is because that after openldap all contents of /usr/libexec are split into subsets or moved into other directory and no one makes use of it. So, to fix this QA warning, delete /usr/libexec. Signed-off-by: Qi Hou <qi.hou@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit aaf496df4cef4703a6d4b380b3f5ddf738753406) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.45.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.45.bb b/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
index 06d2467ec7..82d6619838 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
@@ -188,6 +188,7 @@ do_install_append() {
# Installing slapd under ${sbin} is more FHS and LSB compliance
mv ${D}${libexecdir}/slapd ${D}/${sbindir}/slapd
+ rmdir --ignore-fail-on-non-empty ${D}${libexecdir}
SLAPTOOLS="slapadd slapcat slapdn slapindex slappasswd slaptest slapauth slapacl slapschema"
cd ${D}/${sbindir}/
rm -f ${SLAPTOOLS}