aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-28 22:27:41 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-04 14:53:27 +0000
commitadb341cc7114ad341c39edb2af209d427a5ac1e2 (patch)
treefd29ec0e704c839fc6f7f43de13b9ae1f77c2d63 /meta-oe/recipes-support
parent1f6c0f6fd55520d1564bc2ad6fa4fb6fdfef8a80 (diff)
downloadmeta-openembedded-contrib-adb341cc7114ad341c39edb2af209d427a5ac1e2.tar.gz
mongodb: Pass computed endian variable
If not passed to SCon, it will try to guess it and do it by poking at build host, which wont work in cross environment Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/mongodb/mongodb_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/mongodb/mongodb_git.bb b/meta-oe/recipes-support/mongodb/mongodb_git.bb
index d44d8d3c7f..0ff7d0b59f 100644
--- a/meta-oe/recipes-support/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-support/mongodb/mongodb_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://GNU-AGPL-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788
DEPENDS = "openssl libpcre libpcap zlib python boost"
-inherit scons dos2unix
+inherit scons dos2unix siteinfo
PV = "3.4.6+git${SRCPV}"
SRCREV = "c55eb86ef46ee7aede3b1e2a5d184a7df4bfb5b5"
@@ -58,6 +58,7 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
--use-system-zlib \
--js-engine=none \
--nostrip \
+ --endian=${@base_conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
${PACKAGECONFIG_CONFARGS} \
mongod mongos"