aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-05-24 18:08:37 +0200
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:55:33 -0700
commit1fa26e59ba32ce9e011cac5f756d2ae351898484 (patch)
treef94245a16106fbe5dd1df6095eec8ca8db54b2db /meta-oe/recipes-support
parent6ab9a61fdfb1687f64de1d6d8798820292f9ec8d (diff)
downloadmeta-openembedded-contrib-1fa26e59ba32ce9e011cac5f756d2ae351898484.tar.gz
mime-support: upgrade 3.48 -> 3.62
* Many changes since 2009 (!!!) - most notable: CVE-2014-7209: run-mailcap shellcommand injection. * They added Bellcore license for mailcap.man * There is a later version 3.66 available but tarball is almost empty because with 3.65 they splitted mime-support into several packages Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/mime-support/mime-support_3.62.bb (renamed from meta-oe/recipes-support/mime-support/mime-support_3.48.bb)35
1 files changed, 18 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb b/meta-oe/recipes-support/mime-support/mime-support_3.62.bb
index 1137f5012a..858521b65f 100644
--- a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb
+++ b/meta-oe/recipes-support/mime-support/mime-support_3.62.bb
@@ -1,13 +1,17 @@
SECTION = "base"
SUMMARY = "MIME files 'mime.types' & 'mailcap', and support programs"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://debian/README;md5=36bbe2ace0a05c3fb684b73208fbf30b"
+LICENSE = "PD & Bellcore"
+LICENSE_${PN} = "PD"
+# mailcap.man's license is Bellcore
+LICENSE_${PN}-doc = "PD & Bellcore"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=53c851e31d27c3ea8a6217073a5ff01c"
DEPENDS = "file"
RDEPENDS_${PN} = "perl"
RRECOMMENDS_${PN} = "file"
-SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}-1.tar.gz"
+SRC_URI = "${DEBIAN_MIRROR}/main/m/mime-support/mime-support_${PV}.tar.gz"
+SRC_URI[sha256sum] = "54e0a03e0cd63c7c9fe68a18ead0a2143fd3c327604215f989d85484d0409f4a"
S = "${WORKDIR}/${BPN}"
inherit update-alternatives
@@ -27,22 +31,22 @@ do_install () {
install -d ${D}${mandir}/man8
install -m 644 mime.types ${D}${sysconfdir}/
install -m 644 mailcap ${D}${libdir}/mime/
- install -m 644 mailcap.order ${D}${sysconfdir}/
+ install -m 644 mailcap.order ${D}${sysconfdir}/
install -m 644 mailcap.man ${D}${mandir}/man5/mailcap.5
- install -m 644 mailcap.order.man ${D}${mandir}/man5/mailcap.order.5
-# install -m 755 install-mime ${D}${sbindir}/
-# install -m 644 install-mime.man ${D}${mandir}/man8/install-mime.8
+ install -m 644 mailcap.order.man ${D}${mandir}/man5/mailcap.order.5
+# install -m 755 install-mime ${D}${sbindir}/
+# install -m 644 install-mime.man ${D}${mandir}/man8/install-mime.8
install -m 755 update-mime ${D}${sbindir}/
- install -m 644 update-mime.man ${D}${mandir}/man8/update-mime.8
+ install -m 644 update-mime.man ${D}${mandir}/man8/update-mime.8
install -m 755 run-mailcap ${D}${bindir}/
- install -m 644 run-mailcap.man ${D}${mandir}/man1/run-mailcap.1
-# install -m 644 rfcs/* ${D}${docdir}/
- install -m 644 debian/changelog ${D}${docdir}/changelog.Debian
- install -m 644 debian/README ${D}${docdir}/copyright
+ install -m 644 run-mailcap.man ${D}${mandir}/man1/run-mailcap.1
+# install -m 644 rfcs/* ${D}${docdir}/
+ install -m 644 debian/changelog ${D}${docdir}/changelog.Debian
+ install -m 644 debian/copyright ${D}${docdir}/copyright
install -m 755 debian-view ${D}${libdir}/mime/
- install -m 755 playaudio ${D}${libdir}/mime/
+ install -m 755 playaudio ${D}${libdir}/mime/
install -m 755 playdsp ${D}${libdir}/mime/
- install -m 644 mailcap.entries ${D}${libdir}/mime/packages/mime-support
+ install -m 644 mailcap.entries ${D}${libdir}/mime/packages/mime-support
cd ${D}${mandir}; gzip -9fv */*
cd ${D}${docdir}; gzip -9v *
cd ${D}${docdir}; gunzip copyright.gz
@@ -56,9 +60,6 @@ do_install () {
cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz print.1.gz
}
-SRC_URI[md5sum] = "d6e5d715e331147352c50c158dbdec6d"
-SRC_URI[sha256sum] = "a529c7892cb786f514af71f4ca5a4c3ebc58b538a49ff959c0d97592d38f040a"
-
ALTERNATIVE_PRIORITY = "90"
ALTERNATIVE_${PN} = "mime.types"
ALTERNATIVE_LINK_NAME[mime.types] = "${sysconfdir}/mime.types"