aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2021-06-02 16:14:56 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-04 07:08:13 -0700
commit2d163d0e1857bf11e8518312fe759dbe5cc59a0b (patch)
treedd6f083b2fa530d040b11fbd72302ef14eb150ec /meta-oe/recipes-support
parent1b26441296f942bcebbc48a23148b44bc0340bb5 (diff)
downloadmeta-openembedded-contrib-2d163d0e1857bf11e8518312fe759dbe5cc59a0b.tar.gz
libgpiod: correctly split output files into packages
Currently, the files that should go into libgpiod-ptest are part of either the main library package of libgpiod-tools. Use more fine-grained values for package files variables. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
index 43264782e2..9e4bef7b4c 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
@@ -28,7 +28,21 @@ EXTRA_OECONF = "--enable-tools"
DEPENDS += "autoconf-archive-native"
PACKAGES =+ "${PN}-tools libgpiodcxx ${PN}-python"
-FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}-tools = " \
+ ${bindir}/gpiodetect \
+ ${bindir}/gpioinfo \
+ ${bindir}/gpioget \
+ ${bindir}/gpioset \
+ ${bindir}/gpiofind \
+ ${bindir}/gpiomon \
+"
+FILES_${PN}-ptest += " \
+ ${bindir}/gpiod-test \
+ ${bindir}/gpio-tools-test \
+ ${bindir}/gpio-tools-test.bats \
+ ${bindir}/gpiod-cxx-test \
+ ${libdir}/libgpiomockup.so.* \
+"
FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*.so"
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"