aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2021-06-02 16:15:00 +0200
committerKhem Raj <raj.khem@gmail.com>2021-06-04 07:08:13 -0700
commit977c5f56198f075376f753b0b4178ecb35ad02ec (patch)
tree22266fe47d18f46f761917b90004fcd69aec1620 /meta-oe/recipes-support
parent2530ace540da5a79e8a0e352f353be7c4a92bb53 (diff)
downloadmeta-openembedded-contrib-977c5f56198f075376f753b0b4178ecb35ad02ec.tar.gz
libgpiod: ptest: warn if the gpio-mockup kernel module is not selected
libgpiod test-suites work with the gpio-mockup kernel module. When using linux-yocto, it's enabled using the gpio/mockup.scc kernel feature. Check if this feature is present in KERNEL_FEATURE and warn if not. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
index 874453fbd6..febf625a6b 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
@@ -52,6 +52,13 @@ RRECOMMENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-py
PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}"
do_install_ptest() {
+ if [ "${PREFERRED_PROVIDER_virtual/kernel}" = "linux-yocto" ] && \
+ ${@bb.utils.contains('KERNEL_FEATURES', 'features/gpio/mockup.scc', 'false', 'true',d)}; then
+ bbwarn "libgpiod test-suites need the gpio-mockup
+module and will not work without it. Consider adding
+'features/gpio/mockup.scc' to KERNEL_FEATURES"
+ fi
+
install -d ${D}${PTEST_PATH}/tests
# These are the core C library tests