aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/catch2/catch2_2.13.7.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-08-17 16:39:15 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:58:56 -0700
commit8deb9e96df95372d72b6f682864c887ef39a4dba (patch)
tree60ca7fb2c09d9714c89a34f393cd4d1a8376311e /meta-oe/recipes-test/catch2/catch2_2.13.7.bb
parentc207d6b5ab2ab360aec8e902e868f2845c500aa5 (diff)
downloadmeta-openembedded-contrib-8deb9e96df95372d72b6f682864c887ef39a4dba.tar.gz
catch2: upgrade 2.13.6 -> 2.13.7
Fixes * Added missing <iterator> include in benchmarking. (#2231) * Fixed noexcept build with benchmarking enabled (#2235) * Fixed build for compilers with C++17 support but without C++17 library support (#2195) * JUnit only uses 3 decimal places when reporting durations (#2221) * !mayfail tagged tests are now marked as skipped in JUnit reporter output (#2116) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/catch2/catch2_2.13.7.bb')
-rw-r--r--meta-oe/recipes-test/catch2/catch2_2.13.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/catch2/catch2_2.13.7.bb b/meta-oe/recipes-test/catch2/catch2_2.13.7.bb
new file mode 100644
index 0000000000..3eda96c731
--- /dev/null
+++ b/meta-oe/recipes-test/catch2/catch2_2.13.7.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
+TDD and BDD - using C++11, C++14, C++17 and later."
+AUTHOR = "Phil Nash, Martin Horenovsky and others"
+HOMEPAGE = "https://github.com/catchorg/Catch2"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/catchorg/Catch2.git;branch=v2.x"
+SRCREV = "c4e3767e265808590986d5db6ca1b5532a7f3d13"
+
+S = "${WORKDIR}/git"
+
+inherit cmake python3native
+
+do_install:append() {
+ rm ${D}${datadir}/Catch2/lldbinit
+ rm ${D}${datadir}/Catch2/gdbinit
+ rmdir ${D}${datadir}/Catch2/
+}
+# Header-only library
+RDEPENDS:${PN}-dev = ""
+RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"