aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
diff options
context:
space:
mode:
authorFrederico Cadete <frederico.cadete@awtce.be>2016-06-22 17:29:35 +0200
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit87e83981f4c6cb0c739510e34b0db3c3471db3e5 (patch)
treec60600c199979abd62c08cc32cc0644769451aeb /meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
parentf87dd8d51685a5a346eaa50e8bf5130d050f50f2 (diff)
downloadmeta-openembedded-contrib-87e83981f4c6cb0c739510e34b0db3c3471db3e5.tar.gz
gtest: fix installation in multilib
The installation and pkgconfig patches have to be reworked to consider the install directories from OE. Signed-off-by: Frederico Cadete <frederico.cadete@awtce.be> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 377d67aa7cb902d4a512c3489482fb876b1ec4cd) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch')
-rw-r--r--meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch b/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
deleted file mode 100644
index 0c160b02a9..0000000000
--- a/meta-oe/recipes-test/gtest/gtest/cmake-Add-install-command-for-libraries-and-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 5318983562be6babeb5a6996e7dda4b31acfdba8 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Wed, 30 Jul 2014 16:49:53 -0300
-Subject: [PATCH] cmake: Add install command for libraries and headers
-Organization: O.S. Systems Software LTDA.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- CMakeLists.txt | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 57470c8..281c4c2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -56,6 +56,8 @@ include_directories(
- ${gtest_SOURCE_DIR}/include
- ${gtest_SOURCE_DIR})
-
-+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest DESTINATION include)
-+
- # Where Google Test's libraries can be found.
- link_directories(${gtest_BINARY_DIR}/src)
-
-@@ -71,6 +73,9 @@ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
- cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
- target_link_libraries(gtest_main gtest)
-
-+install(TARGETS gtest DESTINATION lib)
-+install(TARGETS gtest_main DESTINATION lib)
-+
- ########################################################################
- #
- # Samples on how to link user tests with gtest or gtest_main.
---
-1.9.1
-