aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-test
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/bats/bats_1.4.1.bb4
-rw-r--r--meta-oe/recipes-test/catch2/catch2_2.13.6.bb6
-rw-r--r--meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb6
-rw-r--r--meta-oe/recipes-test/cpputest/cpputest_4.0.bb2
-rw-r--r--meta-oe/recipes-test/cunit/cunit_2.1-3.bb4
-rw-r--r--meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb2
-rw-r--r--meta-oe/recipes-test/fwts/fwts_21.06.00.bb12
-rw-r--r--meta-oe/recipes-test/googletest/googletest_git.bb8
-rw-r--r--meta-oe/recipes-test/pm-qa/pm-qa_git.bb4
9 files changed, 24 insertions, 24 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.4.1.bb b/meta-oe/recipes-test/bats/bats_1.4.1.bb
index 214f2af229..b300555494 100644
--- a/meta-oe/recipes-test/bats/bats_1.4.1.bb
+++ b/meta-oe/recipes-test/bats/bats_1.4.1.bb
@@ -19,8 +19,8 @@ do_install() {
${S}/install.sh ${D}${prefix} ${baselib}
}
-RDEPENDS_${PN} = "bash"
-FILES_${PN} += "${libdir}/bats-core/*"
+RDEPENDS:${PN} = "bash"
+FILES:${PN} += "${libdir}/bats-core/*"
PACKAGECONFIG ??= "pretty"
PACKAGECONFIG[pretty] = ",,,ncurses"
diff --git a/meta-oe/recipes-test/catch2/catch2_2.13.6.bb b/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
index fd677a3e38..adfc03a16e 100644
--- a/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
+++ b/meta-oe/recipes-test/catch2/catch2_2.13.6.bb
@@ -12,11 +12,11 @@ S = "${WORKDIR}/git"
inherit cmake python3native
-do_install_append() {
+do_install:append() {
rm ${D}${datadir}/Catch2/lldbinit
rm ${D}${datadir}/Catch2/gdbinit
rmdir ${D}${datadir}/Catch2/
}
# Header-only library
-RDEPENDS_${PN}-dev = ""
-RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+RDEPENDS:${PN}-dev = ""
+RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
diff --git a/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb b/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
index e4afa43e97..59626df07a 100644
--- a/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
+++ b/meta-oe/recipes-test/cmocka/cmocka_1.1.5.bb
@@ -20,7 +20,7 @@ EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DCMAKE_BUILD_TYPE
# Use -Wl,wrap linker flag, which does not work with LTO
LTO = ""
-do_install_append () {
+do_install:append () {
install -d ${D}${datadir}/${BPN}/example
install -d ${D}${datadir}/${BPN}/example/mock/chef_wrap
install -d ${D}${datadir}/${BPN}/example/mock/uptime
@@ -39,5 +39,5 @@ do_install_ptest () {
PACKAGE_BEFORE_PN += "${PN}-examples"
-FILES_${PN}-examples = "${datadir}/${BPN}/example"
-INSANE_SKIP_${PN}-examples = "libdir"
+FILES:${PN}-examples = "${datadir}/${BPN}/example"
+INSANE_SKIP:${PN}-examples = "libdir"
diff --git a/meta-oe/recipes-test/cpputest/cpputest_4.0.bb b/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
index a17c0658c3..e84e03cdb2 100644
--- a/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
+++ b/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
@@ -18,4 +18,4 @@ EXTRA_OECMAKE = "-DLONGLONG=ON \
-DEXTENSIONS=OFF \
"
-FILES_${PN}-dev += "${libdir}/CppUTest/cmake/*"
+FILES:${PN}-dev += "${libdir}/CppUTest/cmake/*"
diff --git a/meta-oe/recipes-test/cunit/cunit_2.1-3.bb b/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
index c877d3bf1c..c71744e3c4 100644
--- a/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
+++ b/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
@@ -31,7 +31,7 @@ do_install_ptest() {
install -m 0755 ${S}${TESTBIN} ${D}${PTEST_PATH}/tests/
}
-FILES_${PN}-dev += "${datadir}/CUnit"
-FILES_${PN}-doc += "${docdir}"
+FILES:${PN}-dev += "${datadir}/CUnit"
+FILES:${PN}-doc += "${docdir}"
BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
index 252eea3665..b760690652 100644
--- a/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
+++ b/meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}/cxxtest-${PV}/python"
inherit distutils3
-do_install_append() {
+do_install:append() {
install -d ${D}${includedir}
cp -a ../cxxtest ${D}${includedir}
sed '1c\
diff --git a/meta-oe/recipes-test/fwts/fwts_21.06.00.bb b/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
index 21d2563514..d33000b8b5 100644
--- a/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
+++ b/meta-oe/recipes-test/fwts/fwts_21.06.00.bb
@@ -18,15 +18,15 @@ SRC_URI[sha256sum] = "ca43439707976f6664fe3f6eb7f356a51ac7d7f8a4e246ef4d1b16305e
COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd"
-DEPENDS_append_libc-musl = " libexecinfo"
+DEPENDS:append:libc-musl = " libexecinfo"
# Use brokensep for now (https://github.com/ColinIanKing/fwts/issues/2)
inherit autotools-brokensep bash-completion pkgconfig
-LDFLAGS_append_libc-musl = " -lexecinfo"
+LDFLAGS:append:libc-musl = " -lexecinfo"
-FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
-FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
-FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
+FILES:${PN} += "${libdir}/fwts/lib*${SOLIBS}"
+FILES:${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
+FILES:${PN}-staticdev += "${libdir}/fwts/lib*a"
-RDEPENDS_${PN} += "dtc"
+RDEPENDS:${PN} += "dtc"
diff --git a/meta-oe/recipes-test/googletest/googletest_git.bb b/meta-oe/recipes-test/googletest/googletest_git.bb
index 3e1fc4ff88..ff8cecc5b2 100644
--- a/meta-oe/recipes-test/googletest/googletest_git.bb
+++ b/meta-oe/recipes-test/googletest/googletest_git.bb
@@ -14,14 +14,14 @@ SRC_URI = "git://github.com/google/googletest.git"
inherit cmake
-ALLOW_EMPTY_${PN} = "1"
-ALLOW_EMPTY_${PN}-dbg = "1"
+ALLOW_EMPTY:${PN} = "1"
+ALLOW_EMPTY:${PN}-dbg = "1"
-RDEPENDS_${PN}-dev += "${PN}-staticdev"
+RDEPENDS:${PN}-dev += "${PN}-staticdev"
BBCLASSEXTEND = "native nativesdk"
-do_configure_prepend() {
+do_configure:prepend() {
# explicitly use python3
# the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
# but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
diff --git a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
index bb641437c9..18ef371e39 100644
--- a/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
+++ b/meta-oe/recipes-test/pm-qa/pm-qa_git.bb
@@ -63,7 +63,7 @@ do_install () {
install -m 0755 $script ${D}${bindir}/${script_basename}
done
}
-RDEPENDS_${PN} +="bash"
+RDEPENDS:${PN} +="bash"
# http://errors.yoctoproject.org/Errors/Details/186956/
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'