aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-06-28 11:48:17 -0700
committerKhem Raj <raj.khem@gmail.com>2018-06-29 00:35:58 -0700
commit0a5c61ce6cf98074dba9934e497a66885874eba7 (patch)
tree091b75e9de35aa243328617e996be561f363d1ee /meta-oe
parent145408acff00f0faf25ee51d34dcb9a63cdb0cd1 (diff)
downloadmeta-openembedded-contrib-0a5c61ce6cf98074dba9934e497a66885874eba7.tar.gz
protobuf: misc recipe cleanup
Re-order variables to align more closely with the OE style-guide. Remove spurious ${bindir} from the protobuf-lite packaging rules. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
index 1ffb79da71..8cef391bd7 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
@@ -5,32 +5,26 @@ all of its internal RPC protocols and file formats."
HOMEPAGE = "https://github.com/google/protobuf"
SECTION = "console/tools"
LICENSE = "BSD-3-Clause"
-
-PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
DEPENDS = "zlib"
-DEPENDS_append_class-target = " protobuf-native"
-RDEPENDS_${PN}-compiler = "${PN}"
-RDEPENDS_${PN}-dev += "${PN}-compiler"
-RDEPENDS_${PN}-ptest = "bash python-protobuf"
-
-LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
+DEPENDS_append_class-target = " protobuf-native"
+PV .= "+git${SRCPV}"
SRCREV = "106ffc04be1abf3ff3399f54ccf149815b287dd9"
-PV = "3.5.1+git${SRCPV}"
-
SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \
- file://run-ptest \
- "
+ file://run-ptest \
+"
-EXTRA_OECONF += " --with-protoc=echo"
+S = "${WORKDIR}/git"
inherit autotools-brokensep pkgconfig ptest
-S = "${WORKDIR}/git"
-TEST_SRC_DIR="examples"
-LANG_SUPPORT="cpp python"
+EXTRA_OECONF += "--with-protoc=echo"
+
+TEST_SRC_DIR = "examples"
+LANG_SUPPORT = "cpp python"
do_compile_ptest() {
# Modify makefile to use the cross-compiler
@@ -76,8 +70,14 @@ do_install_ptest() {
cd "$olddir"
}
+PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
+
FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
-FILES_${PN}-lite = "${bindir} ${libdir}/libprotobuf-lite${SOLIBS}"
+FILES_${PN}-lite = "${libdir}/libprotobuf-lite${SOLIBS}"
+
+RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-dev += "${PN}-compiler"
+RDEPENDS_${PN}-ptest = "bash python-protobuf"
MIPS_INSTRUCTION_SET = "mips"