aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:03:22 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-11 10:03:22 +0200
commit2c7210ea29f890ee8534355cb6fb280e04fb0c66 (patch)
treedef2f20f843110cce9d74705c44cce66a866d58b /meta-oe
parent0f52cc583d829e4df410bbdcd8d487b2f21ccc1b (diff)
downloadmeta-openembedded-contrib-2c7210ea29f890ee8534355cb6fb280e04fb0c66.tar.gz
libsdl-mixer 1.2.11: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch22
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff28
-rw-r--r--meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb38
3 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch
new file mode 100644
index 0000000000..7cc69e057f
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/configure.patch
@@ -0,0 +1,22 @@
+Index: SDL_mixer-1.2.11/configure.in
+===================================================================
+--- SDL_mixer-1.2.11.orig/configure.in 2011-02-15 11:54:23.929086120 +0100
++++ SDL_mixer-1.2.11/configure.in 2011-02-15 11:56:53.745736645 +0100
+@@ -1,6 +1,5 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(README)
+-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
+
+ dnl Set various version strings - taken gratefully from the GTk sources
+
+@@ -40,10 +39,6 @@
+ AC_SUBST(LT_REVISION)
+ AC_SUBST(LT_AGE)
+
+-dnl Detect the canonical build and host environments
+-AC_CONFIG_AUX_DIRS($srcdir/build-scripts)
+-dnl AC_CANONICAL_HOST
+-
+ dnl Check for tools
+ AC_PROG_LIBTOOL
+ AC_PROG_CC
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff
new file mode 100644
index 0000000000..48fe88ef4a
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer/fix-flac-madness.diff
@@ -0,0 +1,28 @@
+--- /tmp/configure.in 2009-12-02 16:18:33.000000000 +0100
++++ SDL_mixer-1.2.11/configure.in 2009-12-02 16:20:02.000000000 +0100
+@@ -413,24 +413,7 @@
+ [], [enable_music_flac_shared=yes])
+ if test x$enable_music_flac = xyes; then
+ AC_CHECK_HEADER([FLAC/export.h], [have_flac_export=yes])
+- if test x$have_flac_export = xyes; then
+- LIBS_SAVED="$LIBS"
+- LIBS="-lFLAC"
+- AC_MSG_CHECKING([for libflac so-name version >= $libflac_ver])
+- AC_TRY_RUN([
+-#include "FLAC/export.h"
+-#include "stdio.h"
+-int main( int argc, char *argv[] ) {
+-#if defined(FLAC_API_VERSION_CURRENT) && (FLAC_API_VERSION_CURRENT >= $libflac_ver)
+- return 0;
+-#else
+- return 1;
+-#endif
+-}
+-], have_flac_ver=yes, have_flac_ver=no)
+- LIBS="$LIBS_SAVED"
+- AC_MSG_RESULT($have_flac_ver)
+- fi
++ have_flac_ver=yes
+
+ if test x$have_flac_ver = xyes; then
+ AC_CHECK_HEADER([FLAC/stream_decoder.h], [have_flac_hdr=yes])
diff --git a/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb
new file mode 100644
index 0000000000..bccbc50fcb
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-mixer/libsdl-mixer_1.2.11.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
+ file://fix-flac-madness.diff \
+ file://configure.patch \
+ "
+SRC_URI[md5sum] = "65ada3d997fe85109191a5fb083f248c"
+SRC_URI[sha256sum] = "86145ac39cac6d2c6169c226f937648dca5e89dcd828751763dd174fa9af9cf9"
+
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+inherit autotools
+
+EXTRA_AUTORECONF += "--include=acinclude"
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
+
+do_configure () {
+ # Remove old libtool macros.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm -f acinclude/$i
+ done
+ cp build-scripts/* . || true
+ rm -rf build-scripts/
+ export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
+
+ autotools_do_configure
+
+ rm config.log
+ for i in $(find -name "Makefile") ; do
+ sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i
+ done
+}
+