aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-09 22:16:06 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-09 22:16:06 +0200
commit375b2e6c6b9d6ed8c0c327e6d32da7a2febddfcf (patch)
treece159e0b37c47f3a393f706bd2dfa6416a4e0383 /meta-oe
parenta0906790ae66f92b993e00ec0c11d0ba6e887266 (diff)
downloadmeta-openembedded-contrib-375b2e6c6b9d6ed8c0c327e6d32da7a2febddfcf.tar.gz
systemd: split out vconsole services into its own subpackage
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 2f977601f8..78af269344 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r6"
+PR = "r7"
inherit pkgconfig autotools vala perlnative
@@ -54,10 +54,14 @@ do_install() {
rm ${D}${base_libdir}/systemd/system/serial-getty* -f
}
-PACKAGES =+ "${PN}-gui"
+PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup"
FILES_${PN}-gui = "${bindir}/systemadm"
+FILES_${PN}-vconsole-setup = "${base_libdir}/systemd/systemd-vconsole-setup \
+ ${base_libdir}/systemd/system/systemd-vconsole-setup.service \
+ ${base_libdir}/systemd/system/sysinit.target.wants/systemd-vconsole-setup.service"
+
FILES_${PN} += " ${base_bindir}/* \
${datadir}/dbus-1/services \
${datadir}/dbus-1/system-services \