aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-01 11:49:08 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 10:24:45 +0200
commit6cba8fe62d10226d2921aeed0a21c7fd18087467 (patch)
tree8c84af40cc2627458e18f19e7c853c3d0a000f2c /meta-oe
parent1f4e99d526e5cb5b4dc7844780734def5423943d (diff)
downloadmeta-openembedded-contrib-6cba8fe62d10226d2921aeed0a21c7fd18087467.tar.gz
python-cython: add patch to fix build error with some distutils packages
* fails with TypeError: unsupported operand type(s) for +: 'NoneType' and 'str' in setup.py when using python-2.6 or python-2.7 (don't know about python-3*) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch27
-rw-r--r--meta-oe/recipes-devtools/python/python-cython_0.15.1.bb5
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch b/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch
new file mode 100644
index 0000000000..9b9dd460bf
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cython-0.15.1/0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch
@@ -0,0 +1,27 @@
+From bfed128dfe9551a3a40b1ac4269f18ecfeac80a9 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sat, 1 Oct 2011 11:46:30 +0200
+Subject: [PATCH] Don't append docs to _Extension.extension.__doc__
+
+* here it fails with TypeError: unsupported operand type(s) for +: 'NoneType' and 'str' in setup.py
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ Cython/Distutils/extension.py | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/Cython/Distutils/extension.py b/Cython/Distutils/extension.py
+index a5a6638..e76c1e7 100644
+--- a/Cython/Distutils/extension.py
++++ b/Cython/Distutils/extension.py
+@@ -16,7 +16,6 @@ except ImportError:
+ warnings = None
+
+ class Extension(_Extension.Extension):
+- _Extension.Extension.__doc__ + \
+ """pyrex_include_dirs : [string]
+ list of directories to search for Pyrex header files (.pxd) (in
+ Unix form for portability)
+--
+1.7.6.1
+
diff --git a/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb b/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
index f22a47391d..3b85601af0 100644
--- a/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
+++ b/meta-oe/recipes-devtools/python/python-cython_0.15.1.bb
@@ -6,8 +6,11 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
SRCNAME = "Cython"
BBCLASSEXTEND = "native"
+PR = "r1"
-SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz \
+ file://0001-Don-t-append-docs-to-_Extension.extension.__doc__.patch \
+"
S = "${WORKDIR}/${SRCNAME}-${PV}"
SRC_URI[md5sum] = "171021b3845c9ca8bd6d8185b3cde664"