aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-10 19:55:16 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-10 19:55:16 +0200
commit9278fe715d5eebd16af1a2d20a92255744913dbb (patch)
tree23fa7944d90227d3e53a2a6214acdaae95f4cef9 /meta-oe
parent2b5f1a5e0c627d49d37d5eac2179c552e85d1c1a (diff)
downloadmeta-openembedded-contrib-9278fe715d5eebd16af1a2d20a92255744913dbb.tar.gz
task-sdk-target: initial add - meant to be what task-sdk-native is in OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/tasks/task-sdk-target.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tasks/task-sdk-target.bb b/meta-oe/recipes-devtools/tasks/task-sdk-target.bb
new file mode 100644
index 0000000000..03141f2d1f
--- /dev/null
+++ b/meta-oe/recipes-devtools/tasks/task-sdk-target.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Packages required for a target (on-device) SDK"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+inherit task allarch
+
+RPROVIDES_${PN} = "task-native-sdk"
+RDEPENDS_${PN} = "gcc-symlinks g++-symlinks cpp cpp-symlinks \
+ binutils-symlinks \
+ perl-modules \
+ flex flex-dev \
+ bison \
+ gawk \
+ sed \
+ grep \
+ autoconf automake \
+ make \
+ patch diffstat diffutils \
+ libstdc++-dev \
+ libtool libtool-dev libltdl-dev \
+ pkgconfig"
+
+# usefull, but not in oe-core/meta-oe yet: patchutils
+RRECOMMENDS_${PN} = " g77-symlinks gfortran-symlinks"