aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-11-05 22:07:32 +0000
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:06 -0800
commita72fc487dad1b8a239efa96b7ea8b156716bd061 (patch)
tree9d1e1848fe1fa42a6c86f389cd693a467c390cdf /meta-oe
parentc80401b416863e14a9122ae36e014c821e178028 (diff)
downloadmeta-openembedded-contrib-a72fc487dad1b8a239efa96b7ea8b156716bd061.tar.gz
dumb-init: New recipe
This is a really simple init replacement for lightweight container images. See https://engineeringblog.yelp.com/2016/01/dumb-init-an-init-for-docker.html for more info. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb b/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb
new file mode 100644
index 0000000000..e1a6d9508b
--- /dev/null
+++ b/meta-oe/recipes-extended/dumb-init/dumb-init_1.2.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Simple wrapper script which proxies signals to a child"
+HOMEPAGE = "https://github.com/Yelp/dumb-init/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5940d39995ea6857d01b8227109c2e9c"
+
+SRC_URI = "https://github.com/Yelp/dumb-init/archive/v${PV}.tar.gz"
+SRC_URI[md5sum] = "4eb7f43d7823686723ff7ac1bad097cb"
+SRC_URI[sha256sum] = "74486997321bd939cad2ee6af030f481d39751bc9aa0ece84ed55f864e309a3f"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS} ${LDFLAGS}'"
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install ${S}/dumb-init ${D}${base_sbindir}/
+}