aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-01-28 17:33:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-15 10:15:26 +0100
commit32ed5e4e15cd595ee41145e7247772f4e5f00b9e (patch)
tree077901c255c2f91d3a205aa4a6e2a73dca068cda /meta-oe
parent33965e42d2d4c941b57f8e865535d83574d16df3 (diff)
downloadmeta-openembedded-contrib-32ed5e4e15cd595ee41145e7247772f4e5f00b9e.tar.gz
start-stop-daemon: Upgrade 1.16.0.2 -> 1.17.25
Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Brad Mouring <brad.mouring@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch39
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb (renamed from meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb)20
2 files changed, 51 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch
new file mode 100644
index 0000000000..e988efded6
--- /dev/null
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon/0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch
@@ -0,0 +1,39 @@
+From 685645a20e39cf2ab7db8d1f5e3666a4228abca8 Mon Sep 17 00:00:00 2001
+From: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
+Date: Wed, 8 Jul 2015 09:44:57 +0300
+Subject: [PATCH 1/1] dpkg start-stop-daemon: Accept SIG prefixed signal names
+
+---
+ utils/start-stop-daemon.c | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/utils/start-stop-daemon.c b/utils/start-stop-daemon.c
+index 6aebe9b..e805082 100644
+--- a/utils/start-stop-daemon.c
++++ b/utils/start-stop-daemon.c
+@@ -18,6 +18,9 @@
+ * and Andreas Schuldei <andreas@schuldei.org>
+ *
+ * Changes by Ian Jackson: added --retry (and associated rearrangements).
++ *
++ * Changes by Haris Okanovic <haris.okanovic@ni.com> to support 'SIG'
++ * prefixed signal names placed in public domain as well.
+ */
+
+ #include <config.h>
+@@ -661,6 +664,12 @@ parse_signal(const char *sig_str, int *sig_num)
+ if (parse_unsigned(sig_str, 10, sig_num) == 0)
+ return 0;
+
++ /* Skip over optional "SIG" prefix */
++ if (strncmp(sig_str, "SIG", 3) == 0) {
++ warning("Using deprecated signal name %s. Drop the 'SIG' prefix.\n", sig_str);
++ sig_str += 3;
++ }
++
+ for (i = 0; i < array_count(siglist); i++) {
+ if (strcmp(sig_str, siglist[i].name) == 0) {
+ *sig_num = siglist[i].signal;
+--
+2.1.4
+
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
index efdd6b714f..5ee4472cd9 100644
--- a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.16.0.2.bb
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
@@ -1,27 +1,26 @@
SUMMARY = "Debian's start-stop-daemon utility extracted from the dpkg \
package"
LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;md5=a963623e4588f70122865aaa7a370ce4"
+LIC_FILES_CHKSUM = "file://utils/start-stop-daemon.c;endline=21;md5=8fbd0497a7d0b01e99820bffcb58e9ad"
# start-stop-daemon is usually shipped by dpkg
DEPENDS = "ncurses"
RCONFLICTS_${PN} = "dpkg"
-PNBLACKLIST[start-stop-daemon] ?= "BROKEN: fails because of gettext, partial fix is available here http://patchwork.openembedded.org/patch/89867/"
+SRC_URI = " \
+ ${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.xz \
+ file://0001-dpkg-start-stop-daemon-Accept-SIG-prefixed-signal-na.patch \
+"
-SRC_URI = "http://sources.openembedded.org/dpkg_${PV}.tar.bz2"
-SRC_URI[md5sum] = "d211a84f38987771a49ad1c0f144334a"
-SRC_URI[sha256sum] = "2a3d4ba83c743b3f004533fdd52372cb7b22f5c1da2042d0a31bbcc2b54c0ea5"
+SRC_URI[md5sum] = "e48fcfdb2162e77d72c2a83432d537ca"
+SRC_URI[sha256sum] = "07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa"
inherit autotools gettext pkgconfig
S = "${WORKDIR}/dpkg-${PV}"
EXTRA_OECONF = " \
- --with-start-stop-daemon \
--without-bz2 \
- --without-install-info \
--without-selinux \
- --without-update-alternatives \
"
do_install_append () {
@@ -29,4 +28,9 @@ do_install_append () {
# is no explicit rule for only installing ssd
find ${D} -type f -not -name "*start-stop-daemon*" -exec rm {} \;
find ${D} -depth -type d -empty -exec rmdir {} \;
+
+ # support for buggy init.d scripts that refer to an alternative
+ # explicit path to start-stop-daemon
+ mkdir -p ${D}/sbin/
+ ln -sf /usr/sbin/start-stop-daemon ${D}/sbin/start-stop-daemon
}