aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2017-06-15 19:47:24 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-19 19:30:40 +0200
commit0ec8bc87066e30177c8b64b45967a3268320aeba (patch)
tree39027a6561042d081234d90989e9308c9e544a49 /meta-oe
parent00f1cc1a85ee736773442cd82f3225ff9f731e8c (diff)
downloadmeta-openembedded-contrib-0ec8bc87066e30177c8b64b45967a3268320aeba.tar.gz
rrdtool: allow configuration to disable nls
When building rrdtool for a 'tiny' distro, that does not have native language support (NLS) in glibc, configure fails with the error: autoreconf: failed to run autopoint: No such file or directory Autopoint is part of gettext but without NLS support we populate the sysroot with gettext-minimal-native rather then the full set of gettext executables. This version does not install autopoint, nor should it. Tell autoreconf to skip the check for the autopoint script regardless of NLS support and use the USE_NLS varible to conditionally enable NLS support. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
index a3aac45dd5..797bcaaeea 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.6.0.bb
@@ -22,7 +22,7 @@ BBCLASSEXTEND = "native"
SYSTEMD_PACKAGES = "rrdcached"
SYSTEMD_SERVICE_rrdcached = "rrdcached.socket rrdcached.service"
-EXTRA_AUTORECONF = "-I m4"
+EXTRA_AUTORECONF = "-I m4 --exclude=autopoint"
PACKAGECONFIG ??= "python perl ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
@@ -49,6 +49,7 @@ EXTRA_OECONF = " \
--disable-lua \
--disable-tcl \
--disable-rpath \
+ --enable-nls=${USE_NLS} \
"
export STAGING_LIBDIR