aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-10-13 16:28:55 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-25 15:31:12 +0200
commit4faba62424b816ba49c2dd95520fc9a9140cf280 (patch)
tree6bb58e3a5e82c6974b25c513893a0de103f419d2 /meta-oe
parent2acaa8f3beae8f673a3fbf6fcfc77eb6230f44cd (diff)
downloadmeta-openembedded-contrib-4faba62424b816ba49c2dd95520fc9a9140cf280.tar.gz
libsocketcan: upgrade to 0.0.10
Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/socketcan/libsocketcan/0001-Use-strcmp-instead-of-sizeof-on-char-string.patch39
-rw-r--r--meta-oe/recipes-extended/socketcan/libsocketcan_0.0.10.bb (renamed from meta-oe/recipes-extended/socketcan/libsocketcan_0.0.9.bb)10
2 files changed, 2 insertions, 47 deletions
diff --git a/meta-oe/recipes-extended/socketcan/libsocketcan/0001-Use-strcmp-instead-of-sizeof-on-char-string.patch b/meta-oe/recipes-extended/socketcan/libsocketcan/0001-Use-strcmp-instead-of-sizeof-on-char-string.patch
deleted file mode 100644
index aa6196ee90..0000000000
--- a/meta-oe/recipes-extended/socketcan/libsocketcan/0001-Use-strcmp-instead-of-sizeof-on-char-string.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 94094cc4ee7ae585da3e5e7e83e7d82b5d6de656 Mon Sep 17 00:00:00 2001
-From: Alexander Stein <alexander.stein@systec-electronic.com>
-Date: Wed, 14 Nov 2012 12:13:06 +0100
-Subject: [PATCH] Use strcmp instead of sizeof on char* string
-
-This bug was detected by the clang warning:
-libsocketcan.c:384:16: warning: argument to 'sizeof' in 'strncmp' call
-is the same expression as the source; did you mean to provide an
-explicit length? [-Wsizeof-pointer-memaccess]
-sizeof(name)) != 0)
-~~~~~~~^~~~~~
-
-Signed-off-by: Alexander Stein <alexander.stein@systec-electronic.com>
-Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
----
-Upstream-Status: Backport
-
- src/libsocketcan.c | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/src/libsocketcan.c b/src/libsocketcan.c
-index fedcbdc..841c2ed 100644
---- a/src/libsocketcan.c
-+++ b/src/libsocketcan.c
-@@ -379,9 +379,8 @@ static int do_get_nl_link(int fd, __u8 acquire, const char *name, void *res)
- nl_msg->nlmsg_len - NLMSG_LENGTH(sizeof(struct ifaddrmsg));
- parse_rtattr(tb, IFLA_MAX, IFLA_RTA(ifi), len);
-
-- if (strncmp
-- ((char *)RTA_DATA(tb[IFLA_IFNAME]), name,
-- sizeof(name)) != 0)
-+ if (strcmp
-+ ((char *)RTA_DATA(tb[IFLA_IFNAME]), name) != 0)
- continue;
-
- if (tb[IFLA_LINKINFO])
---
-1.8.3.1
-
diff --git a/meta-oe/recipes-extended/socketcan/libsocketcan_0.0.9.bb b/meta-oe/recipes-extended/socketcan/libsocketcan_0.0.10.bb
index 98ef73f297..60ca580168 100644
--- a/meta-oe/recipes-extended/socketcan/libsocketcan_0.0.9.bb
+++ b/meta-oe/recipes-extended/socketcan/libsocketcan_0.0.10.bb
@@ -5,16 +5,10 @@ SECTION = "libs/network"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://src/libsocketcan.c;beginline=3;endline=17;md5=97e38adced4385d8fba1ae2437cedee1"
-SRCREV = "e1a224bf1c409adf0c02b07a90deada634e54b88"
+SRCREV = "51f1610160a1707f026f8c2d714a6f7aa3ca232b"
-SRC_URI = "git://git.pengutronix.de/git/tools/libsocketcan.git;protocol=git \
- file://0001-Use-strcmp-instead-of-sizeof-on-char-string.patch \
-"
+SRC_URI = "git://git.pengutronix.de/git/tools/libsocketcan.git;protocol=git"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-
-do_configure_prepend() {
- sed -i -e s:tests/GNUmakefile::g -e s:trunk:0.0.9: ${S}/configure.ac
-}