aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2017-08-24 15:40:10 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:05 +0200
commit9d06ee2622bf2a7496b3e63a355f849e8496cacb (patch)
tree45d5a2891516b201588ff5b39519dec89410a13c /meta-oe
parentdec7c6c75b99edee5f1e2a9ce2f42ecd62a9acb8 (diff)
downloadmeta-openembedded-contrib-9d06ee2622bf2a7496b3e63a355f849e8496cacb.tar.gz
openldap: fix native LDFLAGS build error
LDFLAGS += "-pthread" adds the flag both for native and target builds, however the openldap-native build overwrites the variable inside native.bbclass causing "undefined reference to `pthread_getspecific'" and other linker errors. Change the append to happen after parsing by using the override syntax and thus make sure it executes after native.bbclass (bitbake -e reports pre-expansion value "${BUILD_LDFLAGS} -pthread"). Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.45.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.45.bb b/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
index adbf8ce289..06d2467ec7 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.45.bb
@@ -150,7 +150,7 @@ PACKAGES += "${PN}-overlay-proxycache"
# it was disabled for cross-compiling.
CPPFLAGS_append = " -D_GNU_SOURCE -DURANDOM_DEVICE=\'/dev/urandom\' -fPIC"
-LDFLAGS += "-pthread"
+LDFLAGS_append = " -pthread"
do_configure() {
cp ${STAGING_DATADIR_NATIVE}/libtool/build-aux/ltmain.sh ${S}/build