aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2017-05-26 08:34:10 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:46 +0200
commitce3ad5a67bc06c9a1fc2b2e26bafd33387e6f5df (patch)
tree5a299034ab5dd45a6a28eacff27bd3aab0e24f58 /meta-oe
parentaa2ca3e2d6b41d5475f75e50cbe8fe2e476fc9f6 (diff)
downloadmeta-openembedded-contrib-ce3ad5a67bc06c9a1fc2b2e26bafd33387e6f5df.tar.gz
recipes-support: Move libgpiod to meta-oe directory
Previously it was placed in meta directory which is wrong. Move to meta-oe. Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.bb b/meta-oe/recipes-support/libgpiod/libgpiod.bb
new file mode 100644
index 0000000000..fe56f7b5cb
--- /dev/null
+++ b/meta-oe/recipes-support/libgpiod/libgpiod.bb
@@ -0,0 +1,30 @@
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE = "https://github.com/brgl/libgpiod"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+
+UPSTREAM_CHECK_URI = "git://github.com/brgl/libgpiod/releases"
+
+SRC_URI = "git://github.com/brgl/libgpiod.git"
+
+SRCREV = "7ab5e53b69cce313ba87033a442cabd417f5d895"
+
+PV = "0.2+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+SRC_URI[md5sum] = "68f039487e940c15bbfc50a10ab4715b"
+SRC_URI[sha256sum] = "7d7085d4e9cb811742ca8c5fe03458067efaeaa8abc23968d2e3c56bcc2d2ef8"
+
+inherit autotools pkgconfig
+
+# enable tools
+PACKAGECONFIG ?= "tools"
+
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
+PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,"
+
+PACKAGES += " ${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}/*"