aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2017-01-20 11:59:08 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:19 +0100
commitd77049facb76c9372101ccaa38e6f0523cf6c05d (patch)
treeb56f46350a275ad95471769d83eade2566b40fcf /meta-oe
parentb9c6c88475914f531a3c0008f7dcbc22065876c3 (diff)
downloadmeta-openembedded-contrib-d77049facb76c9372101ccaa38e6f0523cf6c05d.tar.gz
picocom: Fix build
The picocom complains about missing GNU_HASH from the binary during QA stage, this is because the picocom Makefile overrides CPPFLAGS, CFLAGS and LDFLAGS. Fix this by passing those as an argument to make. Moreover, since picocom 1.7 now accepts VERSION variable and the UUCP_LOCK_DIR is set to /var/lock by default, drop the CPPFLAGS override altogether and replace it simply with passing VERSION argument to make to precisely retain the original intention. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/picocom/picocom_1.7.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/picocom/picocom_1.7.bb b/meta-oe/recipes-support/picocom/picocom_1.7.bb
index dbee656098..d2a76c0a94 100644
--- a/meta-oe/recipes-support/picocom/picocom_1.7.bb
+++ b/meta-oe/recipes-support/picocom/picocom_1.7.bb
@@ -9,7 +9,8 @@ SRC_URI = "http://picocom.googlecode.com/files/picocom-${PV}.tar.gz"
SRC_URI[md5sum] = "8eaba1d31407e8408674d6e57af447ef"
SRC_URI[sha256sum] = "d0f31c8f7a215a76922d30c81a52b9a2348c89e02a84935517002b3bc2c1129e"
-CPPFLAGS_append = '-DVERSION_STR=\\"${PV}\\" -DUUCP_LOCK_DIR=\\"/var/lock\\" -DHIGH_BAUD'
+EXTRA_OEMAKE = "'CC=${CC}' 'LD=${LD}' 'VERSION=${PV}' \
+ 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' "
do_install () {
install -d ${D}${bindir}