aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-03-13 12:35:45 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-16 23:34:33 +0100
commit56d0a5607a101e0f8e35c0cd7f46bdee8f32f60d (patch)
tree4a98f246b1161246da9c9b8a54bc531ff3b1f3f1 /meta-oe
parentd6ff17de88327cba5509630fb06d1afe37ffed50 (diff)
downloadmeta-openembedded-contrib-56d0a5607a101e0f8e35c0cd7f46bdee8f32f60d.tar.gz
luajit: test SITEINFO_BITS instead of maintaining a list of 32bit targets
When cross compiling, the word size of the compiler set via HOST_CC must match the word size of the target. That's achieved by appending "-m32" to BUILD_CC_ARCH if the target word size is known to be 32bits. Unfortunately the current list of over-rides may not cover all cases. Using SITEINFO_BITS is a more generic solution. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
index 2049846345..cee9cc428c 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.4.bb
@@ -11,7 +11,7 @@ SRC_URI[sha256sum] = "620fa4eb12375021bef6e4f237cbd2dd5d49e56beb414bee052c746bee
S = "${WORKDIR}/LuaJIT-${PV}"
-inherit pkgconfig binconfig
+inherit pkgconfig binconfig siteinfo
BBCLASSEXTEND = "native"
@@ -21,11 +21,7 @@ BBCLASSEXTEND = "native"
# you need to install the multilib development package (e.g.
# libc6-dev-i386 on Debian/Ubuntu) and build a 32 bit host part
# (HOST_CC="gcc -m32").
-BUILD_CC_ARCH_append_powerpc = ' -m32'
-BUILD_CC_ARCH_append_x86 = ' -m32'
-BUILD_CC_ARCH_append_arm = ' -m32'
-BUILD_CC_ARCH_append_mips = ' -m32'
-BUILD_CC_ARCH_append_mipsel = ' -m32'
+BUILD_CC_ARCH_append = " ${@['-m32',''][d.getVar('SITEINFO_BITS', True) != '32']}"
# The lua makefiles expect the TARGET_SYS to be from uname -s
# Values: Windows, Linux, Darwin, iOS, SunOS, PS3, GNU/kFreeBSD