aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-19 22:31:39 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-31 13:25:56 +0200
commitf67e201820e15c542a05bf67ec49a80ba36ab875 (patch)
treea69c6219151494eb42a443d48459e06e08c4c99f /meta-oe
parent0d48a392d56d6ec9ef0de267f7ee802b3daae8b0 (diff)
downloadmeta-openembedded-contrib-f67e201820e15c542a05bf67ec49a80ba36ab875.tar.gz
libtorrent, rtorrent: Update to latest
libtorrent -> 0.13.6+git rtorrent -> 0.9.6+git Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb (renamed from meta-oe/recipes-connectivity/libtorrent/libtorrent_0.13.3.bb)15
-rw-r--r--meta-oe/recipes-connectivity/rtorrent/rtorrent_git.bb (renamed from meta-oe/recipes-connectivity/rtorrent/rtorrent_0.9.3.bb)12
2 files changed, 20 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.13.3.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
index 4af3a6a6a6..aaebc5f1ba 100644
--- a/meta-oe/recipes-connectivity/libtorrent/libtorrent_0.13.3.bb
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
@@ -4,14 +4,21 @@ HOMEPAGE = "http://libtorrent.rakshasa.no/"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
-DEPENDS = "libsigc++-2.0 openssl cppunit"
+DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
-SRC_URI = "http://libtorrent.rakshasa.no/downloads/${BP}.tar.gz \
+SRC_URI = "git://github.com/rakshasa/libtorrent \
file://don-t-run-code-while-configuring-package.patch \
"
+SRCREV = "c167c5a9e0bcf0df23ae5efd91396aae0e37eb87"
-SRC_URI[md5sum] = "e94f6c590bb02aaf4d58618f738a85f2"
-SRC_URI[sha256sum] = "34317d6783b7f8d0805274c9467475b5432a246c0de8e28fc16e3b0b43f35677"
+PV = "0.13.6+git${SRCPV}"
+
+S = "${WORKDIR}/git"
inherit autotools pkgconfig
+EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
+
+do_configure_prepend() {
+ (cd ${S}; ./autogen.sh; cd -)
+}
diff --git a/meta-oe/recipes-connectivity/rtorrent/rtorrent_0.9.3.bb b/meta-oe/recipes-connectivity/rtorrent/rtorrent_git.bb
index eb0a39af5c..af1c4d656e 100644
--- a/meta-oe/recipes-connectivity/rtorrent/rtorrent_0.9.3.bb
+++ b/meta-oe/recipes-connectivity/rtorrent/rtorrent_git.bb
@@ -5,11 +5,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "libsigc++-2.0 curl cppunit libtorrent ncurses"
-SRC_URI = "http://libtorrent.rakshasa.no/downloads/${BP}.tar.gz \
+SRC_URI = "git://github.com/rakshasa/rtorrent \
file://don-t-run-code-while-configuring-package.patch \
"
+SRCREV = "226e670decf92e7adaa845a6982aca4f164ea740"
-SRC_URI[md5sum] = "0bf2f262faa8c8c8d3b11ce286ea2bf2"
-SRC_URI[sha256sum] = "9e93ca41beb1afe74ad7ad8013e0d53ae3586c9b0e97263d722f721535cc7310"
+PV = "0.9.6+git${SRCPV}"
+
+S = "${WORKDIR}/git"
inherit autotools pkgconfig
+
+do_configure_prepend() {
+ (cd ${S}; ./autogen.sh; cd -)
+}