aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-06-21 16:52:11 +0200
committerKhem Raj <raj.khem@gmail.com>2022-06-30 13:39:29 -0400
commit0b32f0000ce6b93306db7f0d2d72c36b5270e2ab (patch)
tree5d35f1d94b6dbc985ae0270262766cb357cd888d /meta-oe
parent2117bbee2087d9a3ce9040c8e4ae89306b796145 (diff)
downloadmeta-openembedded-contrib-0b32f0000ce6b93306db7f0d2d72c36b5270e2ab.tar.gz
flatbuffers: update to 2.0.6
- fix flatc not found issue - build the python3 module as a separate package to allow proper install - remove fpic CXXFLAG as it seems to be unneeded - use python3-native - remove -DCMAKE_BUILD_TYPE=Release option and its outdated comment. After a long discussion the default behavior was changed: https://github.com/google/flatbuffers/pull/5180 Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb (renamed from meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb)24
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb15
2 files changed, 21 insertions, 18 deletions
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb
index bf74f1229f..3ca4772100 100644
--- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.0.bb
+++ b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_2.0.6.bb
@@ -3,41 +3,29 @@ HOMEPAGE = "https://github.com/google/flatbuffers"
SECTION = "console/tools"
LICENSE = "Apache-2.0"
-inherit python3-dir
+PACKAGE_BEFORE_PN = "${PN}-compiler"
-PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-${PYTHON_PN}"
+DEPENDS = "flatbuffers-native"
RDEPENDS:${PN}-compiler = "${PN}"
-RDEPENDS:${PN}-${PYTHON_PN} = "${PN}"
RDEPENDS:${PN}-dev += "${PN}-compiler"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "a9a295fecf3fbd5a4f571f53b01f63202a3e2113"
+SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396"
SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
CVE_CHECK_IGNORE += "CVE-2020-35864"
-CXXFLAGS += "-fPIC"
-BUILD_CXXFLAGS += "-fPIC"
-
-# BUILD_TYPE=Release is required, otherwise flatc is not installed
-EXTRA_OECMAKE += "\
- -DCMAKE_BUILD_TYPE=Release \
+EXTRA_OECMAKE += " \
-DFLATBUFFERS_BUILD_TESTS=OFF \
-DFLATBUFFERS_BUILD_SHAREDLIB=ON \
"
+EXTRA_OECMAKE:append:class-target = " -DFLATBUFFERS_FLATC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/flatc"
-inherit cmake
-
-do_install:append() {
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}
- cp -rf ${S}/python/flatbuffers ${D}${PYTHON_SITEPACKAGES_DIR}
-}
+inherit cmake python3native
FILES:${PN}-compiler = "${bindir}"
-FILES:${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
-
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb b/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb
new file mode 100644
index 0000000000..cc453da357
--- /dev/null
+++ b/meta-oe/recipes-devtools/flatbuffers/python3-flatbuffers_2.0.6.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Memory Efficient Serialization Library - Python3 Modules"
+HOMEPAGE = "https://github.com/google/flatbuffers"
+SECTION = "console/tools"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://../LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396"
+SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https"
+S = "${WORKDIR}/git/python"
+
+RDEPENDS:${PN} = "flatbuffers"
+
+inherit setuptools3
+