aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-29 23:36:53 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-31 11:06:23 -0800
commit2a9b5f98cb1a844705fb6d5746f99465d0c90650 (patch)
treef0807be7e529f2435f5764c913e8eaa9343be015 /meta-oe
parent13b8e3fc5d091057fff8914a5c42efacaefd63ee (diff)
downloadmeta-openembedded-contrib-2a9b5f98cb1a844705fb6d5746f99465d0c90650.tar.gz
spirv-tools: Upgrade to v2019.5
Drop upstreamed patch backport a patch to fix error: moving a temporary object prevents copy elision [-Werror,-Wpessimizing-move] | std::move(BuildModule(env_, consumer_, original, assemble_options_)); | ^ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch50
-rw-r--r--meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch24
-rw-r--r--meta-oe/recipes-graphics/spir/spirv-tools_git.bb12
3 files changed, 56 insertions, 30 deletions
diff --git a/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch b/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch
new file mode 100644
index 0000000000..9b48cdcd09
--- /dev/null
+++ b/meta-oe/recipes-graphics/spir/files/0001-Avoid-pessimizing-std-move-3124.patch
@@ -0,0 +1,50 @@
+From 4fffcd275b50d08b54b0411679ead98970651bad Mon Sep 17 00:00:00 2001
+From: David Neto <dneto@google.com>
+Date: Fri, 27 Dec 2019 12:05:58 -0500
+Subject: [PATCH] Avoid pessimizing std::move (#3124)
+
+Should fix a warning
+
+Upstream-Status: Backport [https://github.com/KhronosGroup/SPIRV-Tools/commit/8aa423930db37e37086665efcc55944d577c06e5]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ test/opt/pass_fixture.h | 9 +++------
+ 1 file changed, 3 insertions(+), 6 deletions(-)
+
+diff --git a/test/opt/pass_fixture.h b/test/opt/pass_fixture.h
+index 53fb206f..64c089d8 100644
+--- a/test/opt/pass_fixture.h
++++ b/test/opt/pass_fixture.h
+@@ -60,8 +60,7 @@ class PassTest : public TestT {
+ // from pass Process() function.
+ std::tuple<std::vector<uint32_t>, Pass::Status> OptimizeToBinary(
+ Pass* pass, const std::string& original, bool skip_nop) {
+- context_ =
+- std::move(BuildModule(env_, consumer_, original, assemble_options_));
++ context_ = BuildModule(env_, consumer_, original, assemble_options_);
+ EXPECT_NE(nullptr, context()) << "Assembling failed for shader:\n"
+ << original << std::endl;
+ if (!context()) {
+@@ -197,8 +196,7 @@ class PassTest : public TestT {
+ // messages.
+ template <typename PassT, typename... Args>
+ void SinglePassRunAndFail(const std::string& original, Args&&... args) {
+- context_ =
+- std::move(BuildModule(env_, consumer_, original, assemble_options_));
++ context_ = BuildModule(env_, consumer_, original, assemble_options_);
+ EXPECT_NE(nullptr, context()) << "Assembling failed for shader:\n"
+ << original << std::endl;
+ std::ostringstream errs;
+@@ -235,8 +233,7 @@ class PassTest : public TestT {
+ void RunAndCheck(const std::string& original, const std::string& expected) {
+ assert(manager_->NumPasses());
+
+- context_ =
+- std::move(BuildModule(env_, nullptr, original, assemble_options_));
++ context_ = BuildModule(env_, nullptr, original, assemble_options_);
+ ASSERT_NE(nullptr, context());
+
+ context()->set_preserve_bindings(OptimizerOptions()->preserve_bindings_);
+--
+2.24.1
+
diff --git a/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch b/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch
deleted file mode 100644
index e9a45c24fc..0000000000
--- a/meta-oe/recipes-graphics/spir/files/0001-tools-lesspipe-Allow-generic-shell.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 03127fd5a6eff5ae2ebea2e9c6c01fbf1a0a421a Mon Sep 17 00:00:00 2001
-From: Ankit Navik <ankit.tarot@gmail.com>
-Date: Tue, 25 Dec 2018 14:34:09 +0530
-Subject: [PATCH] tools/lesspipe: Allow generic shell
-
-Upstream-Status: Submitted [https://github.com/KhronosGroup/SPIRV-Tools/pull/2255]
-Signed-off-by: Ankit Navik <ankit.tarot@gmail.com>
----
- tools/lesspipe/spirv-lesspipe.sh | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tools/lesspipe/spirv-lesspipe.sh b/tools/lesspipe/spirv-lesspipe.sh
-index 81e3355..f955259 100644
---- a/tools/lesspipe/spirv-lesspipe.sh
-+++ b/tools/lesspipe/spirv-lesspipe.sh
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/usr/bin/env sh
- # Copyright (c) 2016 The Khronos Group Inc.
-
- # Licensed under the Apache License, Version 2.0 (the "License");
---
-2.7.4
-
diff --git a/meta-oe/recipes-graphics/spir/spirv-tools_git.bb b/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
index 49a91b0053..c4db017e8c 100644
--- a/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
+++ b/meta-oe/recipes-graphics/spir/spirv-tools_git.bb
@@ -13,14 +13,14 @@ SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \
git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \
git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \
git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \
- file://0001-tools-lesspipe-Allow-generic-shell.patch \
file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch \
+ file://0001-Avoid-pessimizing-std-move-3124.patch \
"
-SRCREV_spirv-tools = "167f1270a9ee641b17c016a545741e4aadfabe86"
-SRCREV_spirv-headers = "4618b86e9e4b027a22040732dfee35e399cd2c47"
-SRCREV_effcee = "8f0a61dc95e0df18c18e0ac56d83b3fa9d2fe90b"
-SRCREV_re2 = "2cf86e5ab6dcfe045a1f510c2b9a8b012a4158cd"
-SRCREV_googletest = "150613166524c474a8a97df4c01d46b72050c495"
+SRCREV_spirv-tools = "c413b982c316b14e784f50d941814fc737b55b4a"
+SRCREV_spirv-headers = "af64a9e826bf5bb5fcd2434dd71be1e41e922563"
+SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d"
+SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb"
+SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528"
inherit cmake python3native