aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-10-18 21:45:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-27 16:39:34 +0000
commit5d6d21e98ed594809169d2b2f6964e90a3369a96 (patch)
tree4578c243adca101e739da0b68444213d6e904213 /meta-oe
parent3c73befc036fed4506c9bb8adc6c615dd2d2999c (diff)
downloadmeta-openembedded-contrib-5d6d21e98ed594809169d2b2f6964e90a3369a96.tar.gz
libreport: fix Nothing RPROVIDES 'lib32-python3-libreport'
While multilib enabled, if other recipe RDEPENDS python3-libreport, it failed with: ... ERROR: Nothing RPROVIDES 'lib32-python3-libreport' ... Do not use python3-${PN} could fix the issue. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/libreport/libreport_2.9.2.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb b/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
index 2fdfd7d725..525437bdb6 100644
--- a/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
+++ b/meta-oe/recipes-extended/libreport/libreport_2.9.2.bb
@@ -26,7 +26,7 @@ REQUIRED_DISTRO_FEATURES = "systemd"
inherit gettext autotools python3native pkgconfig
-RDEPENDS_${PN}-python3 += "${PN}"
+RDEPENDS_python3-libreport += "${PN}"
do_patch[prefuncs] += "do_gen_version"
do_gen_version() {
@@ -34,9 +34,9 @@ do_gen_version() {
./gen-version
}
-PACKAGES += "python3-${PN}"
+PACKAGES += "python3-libreport"
FILES_${PN} += "${datadir}/*"
FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
-FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+FILES_python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"