aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-15 18:11:02 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-16 13:50:45 +0200
commit852ac4b589adb186191ad70a2fa3472d5b351ec4 (patch)
tree598be2b615f2b9c804f66c15b17ffc37671b6994 /meta-oe
parent3a493483b59cfe700400737a38b8147583685de6 (diff)
downloadmeta-openembedded-contrib-852ac4b589adb186191ad70a2fa3472d5b351ec4.tar.gz
bluez-hcidump: add 2.0 version and patch to build with newer bluez
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch42
-rw-r--r--meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb21
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch b/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
new file mode 100644
index 0000000000..994326514d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/bluez/bluez-hcidump-2.0/remove.ntoh64.definition.patch
@@ -0,0 +1,42 @@
+Upstream-Status: Accepted, already in git, expected to be included in next version after 2.0
+From 95ea4ff5c9c7dbda2f3faaef4e5cd46d542a48c8 Mon Sep 17 00:00:00 2001
+From: Anderson Lizardo <anderson.lizardo@openbossa.org>
+Date: Fri, 18 Mar 2011 15:10:19 -0400
+Subject: [PATCH] Fix compilation against latest BlueZ
+
+BlueZ now has ntoh64()/hton64() functions in bluetooth.h, therefore the
+hcidump local copy is not necessary.
+---
+ src/hcidump.c | 16 ----------------
+ 1 files changed, 0 insertions(+), 16 deletions(-)
+
+diff --git a/src/hcidump.c b/src/hcidump.c
+index af086c7..2023130 100644
+--- a/src/hcidump.c
++++ b/src/hcidump.c
+@@ -50,22 +50,6 @@
+ #include "parser/parser.h"
+ #include "parser/sdp.h"
+
+-#if __BYTE_ORDER == __LITTLE_ENDIAN
+-static inline uint64_t ntoh64(uint64_t n)
+-{
+- uint64_t h;
+- uint64_t tmp = ntohl(n & 0x00000000ffffffff);
+- h = ntohl(n >> 32);
+- h |= tmp << 32;
+- return h;
+-}
+-#elif __BYTE_ORDER == __BIG_ENDIAN
+-#define ntoh64(x) (x)
+-#else
+-#error "Unknown byte order"
+-#endif
+-#define hton64(x) ntoh64(x)
+-
+ #define SNAP_LEN HCI_MAX_FRAME_SIZE
+ #define DEFAULT_PORT "10839";
+
+--
+1.7.4.4
+
diff --git a/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb b/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
new file mode 100644
index 0000000000..7ad8eef323
--- /dev/null
+++ b/meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Linux Bluetooth Stack HCI Debugger Tool."
+DESCRIPTION = "The hcidump tool reads raw HCI data coming from and going to a Bluetooth device \
+and displays the commands, events and data in a human-readable form."
+
+SECTION = "console"
+PRIORITY = "optional"
+DEPENDS = "bluez4"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://src/hcidump.c;beginline=1;endline=23;md5=3bee3a162dff43a5be7470710b99fbcf"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/bluetooth/${P}.tar.gz \
+ file://remove.ntoh64.definition.patch"
+
+SRC_URI[md5sum] = "5c2e3ef0a68b2845047867ba51ff8ac9"
+SRC_URI[sha256sum] = "b3b64fd0b18301df07d3aaf34c037c1e4808b4aaf702294822d62b5424f617fd"
+
+EXTRA_OECONF = "--with-bluez-libs=${STAGING_LIBDIR} --with-bluez-includes=${STAGING_INCDIR}"
+
+inherit autotools