aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-03-31 11:10:09 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-31 12:56:35 +0200
commitfc8a89a479ec90e8450504431ddb22b49e196691 (patch)
tree49d1ad96dc7bb815a1a4330172aedd246d19dcc0 /meta-oe
parentc5e512ae752cfef92f418c0c787c6371d3fa743c (diff)
downloadmeta-openembedded-contrib-fc8a89a479ec90e8450504431ddb22b49e196691.tar.gz
python-cython: import from meta-shr
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/python/python-cython_0.13.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-cython_0.13.bb b/meta-oe/recipes-devtools/python/python-cython_0.13.bb
new file mode 100644
index 0000000000..f705756804
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-cython_0.13.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+SRCNAME = "Cython"
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"
+DEPENDS = "python"
+
+SRC_URI = "http://www.cython.org/release/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "ed2ec5e0df60a6b8e500bedf93bb1feb"
+SRC_URI[sha256sum] = "a30d5e26c82ec65d65703c7cf312161a21b30339addc1a42d3b2965dea254ca6"
+
+inherit distutils