aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-11-04 16:36:58 +0800
committerArmin Kuster <akuster808@gmail.com>2016-11-29 08:22:21 -0800
commitebc3e16c7d698b16c2edfef64eef0c14a6a6a758 (patch)
tree6365d7023e48f40263005cdbe42cc0f7cf96ebe3 /meta-oe
parent54b566a00ac166cdca5b7f696aa10e1a44c3424f (diff)
downloadmeta-openembedded-contrib-ebc3e16c7d698b16c2edfef64eef0c14a6a6a758.tar.gz
edac-utils: fix systemd service
Fix edac-utils systemd service file so that `systemctl stop edac' doesn't fail. Remove the ExecStop line as there's no '--unload' option for edac-ctl. Also, disable edac service by default. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit caf48f2ea58f63b1a91a3d2aeafe98745efe0a50) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/edac-utils/edac-utils_git.bb1
-rw-r--r--meta-oe/recipes-support/edac-utils/files/edac.service1
2 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/edac-utils/edac-utils_git.bb b/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
index b3ff1cc2c9..2c0914d30a 100644
--- a/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
+++ b/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
@@ -44,3 +44,4 @@ do_install_append() {
}
SYSTEMD_SERVICE_${PN} = "edac.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
diff --git a/meta-oe/recipes-support/edac-utils/files/edac.service b/meta-oe/recipes-support/edac-utils/files/edac.service
index 9f687a8af2..f6b211e91b 100644
--- a/meta-oe/recipes-support/edac-utils/files/edac.service
+++ b/meta-oe/recipes-support/edac-utils/files/edac.service
@@ -4,7 +4,6 @@ Description=Initialize EDAC Drivers For Machine Hardware
[Service]
Type=oneshot
ExecStart=@SBINDIR@/edac-ctl --register-labels
-ExecStop=@SBINDIR@/edac-ctl --unload
RemainAfterExit=yes
[Install]