aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-02 21:58:32 -0700
committerArmin Kuster <akuster808@gmail.com>2017-07-17 11:17:47 -0700
commit9e024f4de9ebd9451e47e00c5376e96dbee32c35 (patch)
treed76b8953d0c1f064c632abd3c45c6dc830fbdfdb /meta-oe
parent4a70e7b6876c1ddee402a0e56afbf708fcf6d020 (diff)
downloadmeta-openembedded-contrib-9e024f4de9ebd9451e47e00c5376e96dbee32c35.tar.gz
openipmi: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/openipmi/files/include_sys_types.patch17
-rw-r--r--meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb1
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openipmi/files/include_sys_types.patch b/meta-oe/recipes-support/openipmi/files/include_sys_types.patch
new file mode 100644
index 0000000000..58ec5d8834
--- /dev/null
+++ b/meta-oe/recipes-support/openipmi/files/include_sys_types.patch
@@ -0,0 +1,17 @@
+include sys/types.h for u_int32_t
+
+ui.c:340:5: error: unknown type name 'u_int32_t'; did you mean 'uint32_t'?
+ u_int32_t addr;
+ ^~~~~~~~~
+Index: OpenIPMI-2.0.22/ui/ui.c
+===================================================================
+--- OpenIPMI-2.0.22.orig/ui/ui.c
++++ OpenIPMI-2.0.22/ui/ui.c
+@@ -42,6 +42,7 @@
+ #include <fcntl.h>
+ #include <time.h>
+ #include <sys/time.h>
++#include <sys/types.h>
+ #include <ctype.h>
+
+ #include <OpenIPMI/selector.h>
diff --git a/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb b/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb
index 82e8cac3ec..9f4b0ff266 100644
--- a/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb
+++ b/meta-oe/recipes-support/openipmi/openipmi_2.0.22.bb
@@ -30,6 +30,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/openipmi/OpenIPMI-${PV}.tar.gz \
file://ipmi-init-fix-the-arguments.patch \
file://makefile-add-ldflags.patch \
file://do-not-install-pyc-and-pyo.patch \
+ file://include_sys_types.patch \
file://openipmi-helper \
file://ipmi.service \
"