aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:30:59 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commit6a13d57d0da17ee36749b9d98f745e10dfe26c27 (patch)
tree09660fa05d9ca188d4dc3d5ace35aa87f478dfee /meta-oe
parent5972198b0f23ca7a248247b0c8a91e565eaa30c2 (diff)
downloadmeta-openembedded-contrib-6a13d57d0da17ee36749b9d98f745e10dfe26c27.tar.gz
owfs: move to meta-filesystems and upgrade
- Move owfs from meta-oe to meta-filesystems - Upgrade owfs to 2.9p1 [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rwxr-xr-xmeta-oe/recipes-extended/owfs/owfs/owhttpd60
-rwxr-xr-xmeta-oe/recipes-extended/owfs/owfs/owserver59
-rw-r--r--meta-oe/recipes-extended/owfs/owfs_2.8p20.bb69
3 files changed, 0 insertions, 188 deletions
diff --git a/meta-oe/recipes-extended/owfs/owfs/owhttpd b/meta-oe/recipes-extended/owfs/owfs/owhttpd
deleted file mode 100755
index 5d74d13d9d..0000000000
--- a/meta-oe/recipes-extended/owfs/owfs/owhttpd
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/bin/sh
-
-PATH=/sbin:/bin:/usr/bin
-
-DAEMON="owhttpd"
-
-test -f /usr/bin/${DAEMON} || exit 0
-
-if test -f /etc/default/${DAEMON} ; then
-. /etc/default/${DAEMON}
-else
-:
-fi
-
-if [ "$START_OWHTTPD" != "yes" ]
-then
- exit 0
-fi
-
-
-startdaemon(){
- echo -n "Starting ${DAEMON}: "
- start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
- echo "done"
-}
-
-stopdaemon(){
- echo -n "Stopping ${DAEMON}: "
- start-stop-daemon --stop -p /var/run/${DAEMON}.pid
- echo "done"
-}
-
-
-
-case "$1" in
- start)
- startdaemon
- ;;
- stop)
- stopdaemon
- ;;
- force-reload)
- stopdaemon
- startdaemon
- ;;
- restart)
- stopdaemon
- startdaemon
- ;;
- reload)
- stopdaemon
- startdaemon
- ;;
- *)
- echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/meta-oe/recipes-extended/owfs/owfs/owserver b/meta-oe/recipes-extended/owfs/owfs/owserver
deleted file mode 100755
index b69ea53e37..0000000000
--- a/meta-oe/recipes-extended/owfs/owfs/owserver
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-PATH=/sbin:/bin:/usr/bin
-
-DAEMON="owserver"
-
-test -f /usr/bin/${DAEMON} || exit 0
-
-if test -f /etc/default/${DAEMON} ; then
-. /etc/default/${DAEMON}
-else
-:
-fi
-
-if [ "$START_OWSERVER" != "yes" ]
-then
- exit 0
-fi
-
-startdaemon(){
- echo -n "Starting ${DAEMON}: "
- start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
- echo "done"
-}
-
-stopdaemon(){
- echo -n "Stopping ${DAEMON}: "
- start-stop-daemon --stop -p /var/run/${DAEMON}.pid
- echo "done"
-}
-
-
-
-case "$1" in
- start)
- startdaemon
- ;;
- stop)
- stopdaemon
- ;;
- force-reload)
- stopdaemon
- startdaemon
- ;;
- restart)
- stopdaemon
- startdaemon
- ;;
- reload)
- stopdaemon
- startdaemon
- ;;
- *)
- echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb b/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb
deleted file mode 100644
index 36772cfeef..0000000000
--- a/meta-oe/recipes-extended/owfs/owfs_2.8p20.bb
+++ /dev/null
@@ -1,69 +0,0 @@
-DESCRIPTION = "1-Wire file system"
-HOMEPAGE = "http://www.owfs.org/"
-SECTION = "console/network"
-
-LICENSE = "GPLv2 & LGPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
- file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
-
-DEPENDS = "fuse virtual/libusb0"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
- file://owhttpd \
- file://owserver "
-SRC_URI[md5sum] = "9aebee6c0e724553f5be6a542494eae5"
-SRC_URI[sha256sum] = "2374ce7864927a430da83691eb994382407e2dba492f9789b560d025841cc8ba"
-
-inherit autotools update-rc.d
-
-EXTRA_OECONF = " \
- --with-fuseinclude=${STAGING_INCDIR} \
- --with-fuselib=${STAGING_LIBDIR} \
- --enable-owfs \
- --enable-owhttpd \
- --enable-cache \
- --enable-mt \
- --enable-w1 \
- --disable-swig \
- --disable-owtcl \
- --disable-owphp \
- --disable-owpython \
- --disable-owperl \
-"
-
-do_install_prepend() {
- install -d ${D}${sysconfdir}/default/
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
- install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
-}
-
-PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
-
-DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
-DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
-DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
-DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
-DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
-DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
-DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
-DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
-DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
-
-FILES_owftpd = "${bindir}/owftpd"
-FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
-FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
-FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
- ${bindir}/owdir ${bindir}/owpresent \
- ${bindir}/owget ${bindir}/owside"
-FILES_owmon = "${bindir}/owmon"
-FILES_owtap = "${bindir}/owtap"
-FILES_libowcapi = "${libdir}/libowcapi-*"
-FILES_libow = "${libdir}/libow-*"
-FILES_libownet = "${libdir}/libownet-*"
-
-INITSCRIPT_PACKAGES = "owhttpd owserver"
-INITSCRIPT_NAME_owserver = "owserver"
-INITSCRIPT_NAME_owhttpd = "owhttpd"
-INITSCRIPT_PARAMS_owserver = "defaults 20"
-INITSCRIPT_PARAMS_owhttpd = "defaults 21"