summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-01 13:43:13 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-01 09:00:01 +0200
commit6965f7ab28a356437f600c362650ba8a721ad3e9 (patch)
tree0b72e0167e8ce6f5298b071fd7f45d265d0f1e47 /meta-oe
parentc4f636ad336bf33d986f2bd11086067c18ea5bcc (diff)
downloadmeta-openembedded-contrib-6965f7ab28a356437f600c362650ba8a721ad3e9.tar.gz
systemd_git.bb: Add patch to disable --nonet option
Hi I am not particularly happy with this patch but by letting xsltproc download stylesheets from internet it atleast compiles the thing. But its very slow. So any better solution if someone has suggestion please by all means -Khem Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/use-nonet-for-docbook.patch30
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/use-nonet-for-docbook.patch b/meta-oe/recipes-core/systemd/systemd/use-nonet-for-docbook.patch
new file mode 100644
index 0000000000..e8aa537b47
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/use-nonet-for-docbook.patch
@@ -0,0 +1,30 @@
+We get errors like
+
+| /bin/mkdir -p man/ && /home/kraj/work/angstrom/build/tmp-angstrom_2010_x-uclibc/sysroots/x86_64-linux/usr/bin/xsltproc -o man/systemd.1 --nonet --param funcsynopsis.style
+ "'ansi'" http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl man/systemd.xml
+| I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+| warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
+| cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+| make[1]: *** [man/systemd.1] Error 4
+| make[1]: Leaving directory `/home/kraj/work/angstrom/build/tmp-angstrom_2010_x-uclibc/work/armv5teb-angstrom-linux-uclibceabi/systemd-git-r4/git'
+| make: *** [all] Error 2
+| + die 'oe_runmake failed'
+| + bbfatal 'oe_runmake failed'
+| + echo 'ERROR: oe_runmake failed'
+| ERROR: oe_runmake failed
+| + exit 1
+
+This patch disables --nonet option to xsltproc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- git/Makefile.am.org 2011-06-30 16:07:21.715269183 -0700
++++ git/Makefile.am 2011-06-30 16:07:26.805269182 -0700
+@@ -1315,7 +1315,6 @@ endif
+
+ if HAVE_XSLTPROC
+ XSLTPROC_FLAGS = \
+- --nonet \
+ --param funcsynopsis.style "'ansi'"
+
+ XSLTPROC_PROCESS_MAN = \
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index c750b2f7c1..40b93b8e59 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -15,7 +15,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r4"
+PR = "r5"
inherit autotools vala
@@ -24,6 +24,7 @@ SRCREV = "8585357a0e5e9f4d56e999d7cd1a73e77ae0eb80"
SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
file://0001-systemd-disable-xml-file-stuff-and-introspection.patch \
file://paper-over-mkostemp.patch \
+ file://use-nonet-for-docbook.patch \
"
S = "${WORKDIR}/git"