aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorNiko Mauno <niko.mauno@vaisala.com>2023-01-24 12:08:13 +0000
committerKhem Raj <raj.khem@gmail.com>2023-01-25 08:51:25 -0800
commit6a87f2ba9cdd4b9689b0d1c86b2e99071d1e069b (patch)
tree0fdd03919bc40460c490c73aa0f416561347f878 /meta-oe
parent61598be67d1da6e74bd8e98c467a2b6edeb61739 (diff)
downloadmeta-openembedded-contrib-6a87f2ba9cdd4b9689b0d1c86b2e99071d1e069b.tar.gz
Fix missing leading whitespace with ':append'
Mitigate occurences where ':append' operator is used and leading whitespace character is obviously missing, risking inadvertent string concatenation. Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb2
-rw-r--r--meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb2
-rw-r--r--meta-oe/recipes-support/neon/neon_0.32.4.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
index c8dabc5ead..44804545de 100644
--- a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
+++ b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
file://0001-Include-typeinfo-for-typeid.patch \
file://0001-include-utility-header.patch \
"
-SRC_URI:append:libc-musl = "file://fix_build_musl.patch"
+SRC_URI:append:libc-musl = " file://fix_build_musl.patch"
SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
DEPENDS = "\
diff --git a/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
index c95a5b2d32..1c2c6e21e0 100644
--- a/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
+++ b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git"
DEPENDS = "openssl"
-EXTRA_OEMAKE:append = "PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1"
+EXTRA_OEMAKE:append = " PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1"
# We want to statically link the binary to libfsverity on native Windows
EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1"
EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1"
diff --git a/meta-oe/recipes-support/neon/neon_0.32.4.bb b/meta-oe/recipes-support/neon/neon_0.32.4.bb
index c16a2c10a7..d281bfde62 100644
--- a/meta-oe/recipes-support/neon/neon_0.32.4.bb
+++ b/meta-oe/recipes-support/neon/neon_0.32.4.bb
@@ -33,7 +33,7 @@ PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
EXTRA_OECONF += "--enable-shared --enable-threadsafe-ssl=posix"
# Do not install into /usr/local
-EXTRA_OEMAKE:append:class-native = "prefix=${prefix_native}"
+EXTRA_OEMAKE:append:class-native = " prefix=${prefix_native}"
do_configure:prepend() {
echo "${PV}" > ${S}/.version