aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-15 21:30:41 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-18 08:33:07 -0700
commitde60098b876e851731487a447602d0bba65ed9b2 (patch)
tree0583a9d8ff35ca0ce88b47e3f2301c8662bf5b14 /meta-oe
parent8910327c6a0a694004423071a3fcf47ea33cbaa7 (diff)
downloadmeta-openembedded-contrib-de60098b876e851731487a447602d0bba65ed9b2.tar.gz
mongodb: Enable wiredtiger only on aarch64/x86_64 hosts
Other 64bit arch where its enabled is ppc64le and it does not compile since build/opt/third_party/wiredtiger/src/checksum/power8/crc32.o is not built, its not setting HOST_ARCH to ppc64le due to cross compiling Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index 95e0cf7a88..9c1e485b31 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -61,6 +61,9 @@ PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
MONGO_ARCH ?= "${HOST_ARCH}"
MONGO_ARCH_powerpc64le = "ppc64le"
+WIREDTIGER ?= "off"
+WIREDTIGER_x86-64 = "on"
+WIREDTIGER_aarch64 = "on"
EXTRA_OESCONS = "PREFIX=${prefix} \
DESTDIR=${D} \
@@ -75,7 +78,7 @@ EXTRA_OESCONS = "PREFIX=${prefix} \
--use-system-zlib \
--nostrip \
--endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
- --wiredtiger=${@['off','on'][d.getVar('SITEINFO_BITS') != '32']} \
+ --wiredtiger='${WIREDTIGER}' \
--separate-debug \
${PACKAGECONFIG_CONFARGS}"