aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorCaio Toledo <caioviniciusdetoledo@gmail.com>2020-12-15 14:56:06 +0000
committerKhem Raj <raj.khem@gmail.com>2020-12-17 09:12:27 -0800
commit7282a97430a1ea24e516ad95b6a36c5751b9d256 (patch)
tree9f3e6b67c0c8a7527077b61f5cbe1a9925cec949 /meta-oe
parentaf6f068632281f8abd42dd3e3301eddd2b0d3ae4 (diff)
downloadmeta-openembedded-contrib-7282a97430a1ea24e516ad95b6a36c5751b9d256.tar.gz
Add recipe for dbus-cxx
Signed-off-by: Caio Toledo <caioviniciusdetoledo@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/dbus-cxx/dbus-cxx_0.12.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_0.12.bb b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_0.12.bb
new file mode 100644
index 0000000000..44f8180bc9
--- /dev/null
+++ b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_0.12.bb
@@ -0,0 +1,24 @@
+SUMMARY = "D-Bus wrapper in C++ for dbus"
+HOMEPAGE = "https://dbus-cxx.github.io/"
+SECTION = "base"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
+
+SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master"
+SRCREV = "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e"
+
+DEPENDS = "\
+ dbus \
+ libsigc++-2.0 \
+"
+
+RDEPENDS_${PN} = "\
+ dbus \
+ libsigc++-2.0 \
+"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"