aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb
diff options
context:
space:
mode:
authorDai Caiyun <daicy.fnst@cn.fujitsu.com>2016-08-22 13:42:21 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-31 18:21:59 +0200
commit62799e1a83138020af08f0116e6cef37efea95ec (patch)
tree459462be59b5ad71a449a97117b516926d9baa01 /meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb
parentc0e4ad71a461f50d06d6c141e965c1f892b850a0 (diff)
downloadmeta-openembedded-contrib-62799e1a83138020af08f0116e6cef37efea95ec.tar.gz
libnet-dns-perl: 0.81 -> 1.06.
1)Upgrade libnet-dns-perl from 0.81 to 1.06. 2)Modify LIC_FILES_CHKSUM, since the date in it has been changed, But the LICENSE has not been changed. Signed-off-by: Dai Caiyun <daicy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb
new file mode 100644
index 0000000000..3702e4a030
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.06.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This package contains the DNS.pm module with friends."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://README;md5=10b1fae0c40a1627bdf0b2a7ac431632"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "ed17abd6e7e3ba0a8db42649e34a53ae"
+SRC_URI[sha256sum] = "a3587b780ca36a8255180ac723d4f6e11407504b5b9a18e0ec098a11c218a51e"
+
+S = "${WORKDIR}/Net-DNS-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+BBCLASSEXTEND = "native"