aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-03-15 02:35:37 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-22 13:31:31 +0100
commitb3ddf559a241cba5a4a4f9ac9314dd501b45c6cc (patch)
tree21d477db4ebefb918d318bfd0f42bd8af7ad3cdc /meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
parent6c584374a599f6f8d3607f20ecfc13a67ccf1da1 (diff)
downloadmeta-openembedded-contrib-b3ddf559a241cba5a4a4f9ac9314dd501b45c6cc.tar.gz
libnet-ssleay-perl: Update to 1.80
Updated LICENSE to reflect actual on website Fixes musl compile error. addresses many compatability issue with the newer openssl drop to backported patch now in this version http://cpansearch.perl.org/src/MIKEM/Net-SSLeay-1.80/Changes Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
new file mode 100644
index 0000000000..32d92ba65a
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.80.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
+DESCRIPTION = "This module offers some high level convenience functions for accessing \
+web pages on SSL servers (for symmetry, same API is offered for \
+accessing http servers, too), a sslcat() function for writing your own \
+clients, and finally access to the SSL api of SSLeay/OpenSSL package \
+so you can write servers or clients for more complicated applications."
+HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
+SECTION = "libs"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
+
+DEPENDS = "openssl zlib"
+RDEPENDS_${PN} += "perl-module-carp \
+ perl-module-errno \
+ perl-module-extutils-makemaker \
+ perl-module-mime-base64 \
+ perl-module-socket \
+ "
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
+ file://run-ptest \
+ "
+SRC_URI[md5sum] = "b1e0fd96d7f3be57580377226ca5f089"
+SRC_URI[sha256sum] = "a541a66d59fc5f9bb7af09d3a0b68305e4c43ba9488b12915728fd282ea01b93"
+
+S = "${WORKDIR}/Net-SSLeay-${PV}"
+
+inherit cpan ptest
+
+EXTRA_CPANFLAGS = "LIBS='-L=${STAGING_LIBDIR} -L=${STAGING_BASELIBDIR}' \
+ INC=-I=${STAGING_INCDIR} \
+ '-lssl -lcrypto -lz' \
+ "
+
+do_install_ptest() {
+ cp -r ${B}/t ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
+
+RDEPENDS_${PN}-ptest = " perl"