aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-20 21:56:17 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 14:36:05 -0800
commitd293b05f546871c8fac59562c5910d6e789c3f10 (patch)
tree740a8ce0e6743a9dcc70a4fcf1fbe2fac11edb25 /meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb
parent3ac873ad8c5dce4feefef8b8e82f80d6939a818d (diff)
downloadmeta-openembedded-contrib-timo/meta-perl-upgrades.tar.gz
libxml-libxml-perl: upgrade 2.0131 -> 2.0132timo/meta-perl-upgrades
* Fix RDEPENDS Changes: 2.0132 2017-10-28 - Revert setNamespace() enhancements that broke some dependent tests: - commit df9fdc6659cb2e4e9bc896e58c02dfd79b430fbb - add t/48_rt123379_setNamespace.t . - Thanks to Alexander Bluhm and Slaven Rezic for the reports and the test. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb
new file mode 100644
index 0000000000..1f18401180
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0132.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Perl interface to the libxml2 library"
+DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
+with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
+interface and a XML::XPath-like interface to XPath API of libxml2. \
+The module is split into several packages which are not described in this \
+section; unless stated otherwise, you only need to use XML::LibXML; in \
+your programs."
+
+HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0|GPLv1+"
+DEPENDS += "libxml2 \
+ libxml-sax-perl-native \
+ zlib \
+"
+RDEPENDS_${PN} += "\
+ libxml2 \
+ libxml-sax-perl \
+ libxml-sax-base-perl \
+ perl-module-encode \
+ perl-module-data-dumper \
+ zlib \
+"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
+ file://disable-libxml2-check.patch \
+ file://fix-CATALOG-conditional-compile.patch \
+ file://using-DOCB-conditional.patch \
+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \
+ file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \
+"
+SRC_URI[libxml.md5sum] = "43546fd9a3974f19323f9fb04861ece9"
+SRC_URI[libxml.sha256sum] = "721452e3103ca188f5968ab06d5ba29fe8e00e49f4767790882095050312d476"
+
+S = "${WORKDIR}/XML-LibXML-${PV}"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
+
+BBCLASSEXTEND = "native"
+
+CFLAGS += " -D_GNU_SOURCE "
+BUILD_CFLAGS += " -D_GNU_SOURCE "
+
+FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"