aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-08-22 16:13:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:03 +0200
commit661541fb67e2c368ecbe3e966daf878a2b48eae1 (patch)
treefd8c3da9e8efd1e171217b0c57cd10520a413698 /meta-perl/recipes-perl
parentff017c9bedc96036b41379893546b41a1cc08b40 (diff)
downloadmeta-openembedded-contrib-661541fb67e2c368ecbe3e966daf878a2b48eae1.tar.gz
adduser: use get_perl_version instead of PERLVERSION
Immediate expansion for PERLVERSION(in perl-version.bbclass) is too early, it will result in 'None' before perl is built, then the module file is installed incorrectly: $ rpm -ql adduser|grep Common /usr/lib/perl/None/Debian/AdduserCommon.pm So use get_perl_version directly instead of PERLVERSION. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl')
-rw-r--r--meta-perl/recipes-perl/adduser/adduser_3.115.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/adduser/adduser_3.115.bb b/meta-perl/recipes-perl/adduser/adduser_3.115.bb
index 81068d6007..c21186231f 100644
--- a/meta-perl/recipes-perl/adduser/adduser_3.115.bb
+++ b/meta-perl/recipes-perl/adduser/adduser_3.115.bb
@@ -22,8 +22,7 @@ do_install() {
install -m 0755 ${S}/adduser ${D}${sbindir}
install -m 0755 ${S}/deluser ${D}${sbindir}
- install -d ${D}${libdir}/perl/${PERLVERSION}/Debian
- install -m 0644 ${S}/AdduserCommon.pm ${D}${libdir}/perl/${PERLVERSION}/Debian
+ install -D -m 0644 ${S}/AdduserCommon.pm ${D}${libdir}/perl/${@get_perl_version(d)}/Debian/AdduserCommon.pm
sed -i -e "s/VERSION/${PV}/" ${D}${sbindir}/*
install -d ${D}/${sysconfdir}