aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2016-01-04 09:14:01 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-06 13:27:21 +0100
commit73af5c278f6617149a46b2d2a1549bc154fa79e5 (patch)
treeecb8f80d1f75fff561ee9cd7af6c40bddf2c5afe /meta-perl
parentfd66e4713e03a5ff9962dfd439033d1ee3e102ca (diff)
downloadmeta-openembedded-contrib-73af5c278f6617149a46b2d2a1549bc154fa79e5.tar.gz
mime-construct: Perform more mangling for perl path
native perl is in /usr/bin/mime-construct, introduce the below QA warning, it should be replaced: WARNING: QA Issue: /usr/bin/mime-construct_mime-construct contained in package mime-construct requires tmp/sysroots/x86_64-linux/usr/bin/perl-native/perl, but no providers found in its RDEPENDS [file-rdeps] Signed-off-by: Roy Li <rongqing.li@windriver.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
index 9f1a779820..501f3bf140 100644
--- a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
+++ b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb
@@ -20,3 +20,9 @@ inherit cpan
RDEPENDS_${PN} = "libmime-types-perl libproc-waitstat-perl msmtp \
perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
"
+
+do_install_append() {
+ #change the interpreter in file
+ sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
+ ${D}/${bindir}/mime-construct
+}