aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-30 15:55:47 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-31 10:06:32 -0700
commit42818f4d8fc0699cc0aa00577e01ff753790d7e1 (patch)
tree330fba174d22bdcbffe258da501e96363108892e /meta-perl
parent704014e5a9106edb90ba21e4671bdfd5010720b1 (diff)
downloadmeta-openembedded-contrib-42818f4d8fc0699cc0aa00577e01ff753790d7e1.tar.gz
libcurses-perl: Fix main prototype in testtyp.c
Enable widechar support based on ENABLE_WIDEC Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch40
-rw-r--r--meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb10
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch b/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch
new file mode 100644
index 0000000000..ab5af3fa8c
--- /dev/null
+++ b/meta-perl/recipes-perl/libcurses/libcurses-perl/0001-testtyp.c-Use-proper-prototype-for-main-function.patch
@@ -0,0 +1,40 @@
+From 01d0904a987ec3d8850ae3b54252c9d3bbe75962 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 30 Aug 2022 15:43:42 -0700
+Subject: [PATCH] testtyp.c: Use proper prototype for main function
+
+Newer compilers like clang-15+ will complain about the prototype
+vigorously, and the test will end up failing for this reason instead of
+real check it should be failing/passing for.
+
+Fixes
+testint.c:11:1: error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Wimplicit-int]
+main() {
+^
+int
+1 error generated.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ testtyp.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/testtyp.c b/testtyp.c
+index 949c3d4..4042f73 100644
+--- a/testtyp.c
++++ b/testtyp.c
+@@ -7,7 +7,8 @@
+ #define _XOPEN_SOURCE_EXTENDED 1 /* We expect wide character functions */
+
+ #include "c-config.h"
+-
+-main() {
++int
++main(int argc, char *argv[]) {
+ typedef SYM c_sym_t;
++ return 0;
+ }
+--
+2.37.3
+
diff --git a/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb b/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb
index 6a6f012fd7..421823d9cd 100644
--- a/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb
+++ b/meta-perl/recipes-perl/libcurses/libcurses-perl_1.41.bb
@@ -8,13 +8,19 @@ LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a
DEPENDS += "perl ncurses "
-SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz"
+SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz \
+ file://0001-testtyp.c-Use-proper-prototype-for-main-function.patch \
+ "
SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7"
S = "${WORKDIR}/Curses-${PV}"
-EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
+EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR} TEST_SYMS_OPTS=-v"
+
+# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
+# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
+CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'} -DNCURSES_INTERNALS"
inherit cpan