aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-10-30 18:44:34 -0700
committerKhem Raj <raj.khem@gmail.com>2022-10-30 23:01:26 -0700
commit5c927fc443606ae6c2ce0fa680935b53666dd8b6 (patch)
treeaad3083e4e242446920e515d00a414f35ae89cbf /meta-perl
parent74c84f4c1159310e8e1e03d20a57aa4ab009fc9d (diff)
downloadmeta-openembedded-contrib-5c927fc443606ae6c2ce0fa680935b53666dd8b6.tar.gz
libcompress-raw-*-perl: cleanup; fixes
* Add SUMMARY * Fix HOMEPAGE * Fix RDEPENDS * Use README for LIC_FILES_CHKSUM Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-bzip2-perl_2.096.bb11
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-lzma-perl_2.096.bb19
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb16
3 files changed, 21 insertions, 25 deletions
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-bzip2-perl_2.096.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-bzip2-perl_2.096.bb
index ef69987ea3..238c988850 100644
--- a/meta-perl/recipes-perl/libcompress/libcompress-raw-bzip2-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-bzip2-perl_2.096.bb
@@ -1,16 +1,13 @@
+SUMMARY = "Low-Level Interface to bzip2 compression library"
DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \
compression/uncompression functions from the bzip2 compression library."
-
+HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Bzip2"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-MAINTAINER= "Poky <poky@yoctoproject.org>"
-HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Bzip2"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
-file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=33084b7f607ba5d38a64b22f8e332f87"
-SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-2.096.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-${PV}.tar.gz"
SRC_URI[md5sum] = "4fdb7ea5071e4b774c52c37331386355"
SRC_URI[sha256sum] = "a564e7634eca7740c5487d01effe1461e9e51b8909e69b3d8f5be98997958cbe"
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-lzma-perl_2.096.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-lzma-perl_2.096.bb
index 04295cd3c6..0cd876be45 100644
--- a/meta-perl/recipes-perl/libcompress/libcompress-raw-lzma-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-lzma-perl_2.096.bb
@@ -1,16 +1,13 @@
-DESCRIPTION = ""Compress::Raw::Lzma" provides an interface to the in-memory \
-compression/uncompression functions from the lzma compression library."
-
+SUMMARY = "Low-Level Interface to lzma compresion library."
+DESCRIPTION = "This module provides a Perl interface to allow reading and \
+wrting of lzma, lzip and xz files/buffers."
+HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Lzma"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-MAINTAINER= "Poky <poky@yoctoproject.org>"
-HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Lzma"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
-file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=2d411393b876fe63f9f1d546363f1a47"
-SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Lzma-2.096.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Lzma-${PV}.tar.gz"
SRC_URI[md5sum] = "b5079bb43712fcd1e74b80777fa376ed"
SRC_URI[sha256sum] = "f3afb267b1303b0f125976e9e4a70c6a4a205e35e7c99b408911f5e5c6578217"
@@ -21,6 +18,10 @@ S = "${WORKDIR}/Compress-Raw-Lzma-${PV}"
inherit cpan
+RDEPENDS:${PN} += "\
+ perl-module-universal \
+"
+
export LIBLZMA_INCLUDE="-I${STAGING_DIR_HOST}${includedir}"
export LIBLZMA_LIB="-I${STAGING_DIR_HOST}${libdir}"
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
index 81c370df2a..dcd5badab9 100644
--- a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.096.bb
@@ -1,16 +1,14 @@
-DESCRIPTION = "The *Compress::Raw::Zlib* module provides a Perl interface to the *zlib* \
-compression library (see "AUTHOR" for details about where to get *zlib*)."
-
+SUMMARY = "Perl interface to the zlib compression library."
+DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
+to the zlib compression library (see 'AUTHOR' for details about where to \
+get zlib)."
+HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-MAINTAINER= "Poky <poky@yoctoproject.org>"
-HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Zlib"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
-file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=603fa463887aed6bb3f6f2a999aca775"
-SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Zlib-2.096.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
SRC_URI[md5sum] = "4144ecdd901231553447998cf8035e4a"
SRC_URI[sha256sum] = "cd4cba20c159a7748b8bc91278524a7da70573d9531fde62298609a5f1c65912"