aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-02-08 16:41:05 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:33 +0100
commitc0416d417115fbae55d83c2d9fa3f3fca1a9e1a0 (patch)
tree736e6105b8c806dca31717638a8f4856de73e277 /meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb
parent09d3d5631681e62a8bcec3f3b8233ec65151f753 (diff)
downloadmeta-openembedded-contrib-c0416d417115fbae55d83c2d9fa3f3fca1a9e1a0.tar.gz
python-thrift: update to version 0.10.0
* Verified license remains the same * Added a set of RDEPENDS for minimal environments Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb')
-rw-r--r--meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb
new file mode 100644
index 0000000000..e6f61bdd0f
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-thrift/python-thrift_0.10.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Python bindings for the Apache Thrift RPC system"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=26a2009ddcb7c4162f8bafd5ef73c670"
+
+SRC_URI[md5sum] = "76bb768a210257dd203923110042e560"
+SRC_URI[sha256sum] = "b7f6c09155321169af03f9fb20dc15a4a0c7481e7c334a5ba8f7f0d864633209"
+
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"