aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commitdff4ea697125cb743b8ac5ae939394a4f05bf6f8 (patch)
tree33df944bad9d9ce293cf73be2d2537f71572d3ab /meta-python/recipes-connectivity
parentec534b23654d6609f483a8603fb61d15caab32d7 (diff)
downloadmeta-openembedded-contrib-dff4ea697125cb743b8ac5ae939394a4f05bf6f8.tar.gz
python-gsocketpool: Add support for python3
Extend recipe to support python3 Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc16
-rw-r--r--meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb18
-rw-r--r--meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc
new file mode 100644
index 0000000000..54dd49f1f0
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool.inc
@@ -0,0 +1,16 @@
+SUMMARY = "A simple connection pool for gevent"
+DESCRIPTION = "creates a pool of connections that can be used with gevent"
+HOMEPAGE = "https://github.com/studio-ousia/gsocketpool"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
+DEPENDS += "${PYTHON_PN}-gevent"
+RDEPENDS_${PN} += "${PYTHON_PN}-gevent"
+
+SRC_URI_append = " \
+ file://0001-fix_setup_py.patch;patch=1;pnum=1 \
+"
+
+SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49"
+SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0"
+
+inherit pypi
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
index f86152c4a6..e96ad1ca1b 100644
--- a/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
+++ b/meta-python/recipes-connectivity/python-gsocketpool/python-gsocketpool_0.1.5.bb
@@ -1,16 +1,2 @@
-SUMMARY = "A simple connection pool for gevent"
-DESCRIPTION = "creates a pool of connections that can be used with gevent"
-HOMEPAGE = "https://github.com/studio-ousia/gsocketpool"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
-DEPENDS += "python-gevent"
-RDEPENDS_${PN} += "python-gevent"
-
-SRC_URI_append = " \
- file://0001-fix_setup_py.patch;patch=1;pnum=1 \
-"
-
-SRC_URI[md5sum] = "04f618864b18d6b06f774994f172ef49"
-SRC_URI[sha256sum] = "b6b73deab9bcbc428d4813697eebe5c3b9c40a971f62e13607b881aa749af9d0"
-
-inherit pypi setuptools
+require python-gsocketpool.inc
+inherit setuptools
diff --git a/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb
new file mode 100644
index 0000000000..883621e214
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-gsocketpool/python3-gsocketpool_0.1.5.bb
@@ -0,0 +1,2 @@
+require python-gsocketpool.inc
+inherit setuptools3