aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/gyp
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-04 16:47:11 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-07 11:28:04 -0700
commitb3b0e2982012b24b6ca7a41259e853cd5906dba1 (patch)
treec5d9016ba2903935f29d3c746f3ce5774a97f456 /meta-python/recipes-devtools/gyp
parenta5fca554e9f36c839d1b228788f3462c1571c8e9 (diff)
downloadmeta-openembedded-contrib-b3b0e2982012b24b6ca7a41259e853cd5906dba1.tar.gz
gyp: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/gyp')
-rw-r--r--meta-python/recipes-devtools/gyp/gyp.inc13
-rw-r--r--meta-python/recipes-devtools/gyp/gyp_git.bb15
2 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp.inc b/meta-python/recipes-devtools/gyp/gyp.inc
deleted file mode 100644
index 98ed42cc90..0000000000
--- a/meta-python/recipes-devtools/gyp/gyp.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
-HOMEPAGE = "https://gyp.gsrc.io/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
-SECTION = "devel"
-
-SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
-SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
-
-S = "${WORKDIR}/git"
-PV = "0.1+git${SRCPV}"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
index 8e48a27fae..61f3c86370 100644
--- a/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,2 +1,15 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
inherit setuptools3
-require gyp.inc
+
+BBCLASSEXTEND = "native nativesdk"