aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-06-20 12:20:05 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:01 +0200
commit12e8df00c0282938363f2400b520f64d31222f51 (patch)
treee6228a7a74e9cd9b0d8ee4e781cd97ed7368b7cc /meta-python/recipes-devtools/python/python-astroid_1.5.3.bb
parent488533cf2c5bde7244d5c65ee5b13684896eb7ad (diff)
downloadmeta-openembedded-contrib-12e8df00c0282938363f2400b520f64d31222f51.tar.gz
python-astroid: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-astroid_1.5.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-astroid_1.5.3.bb22
1 files changed, 6 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb b/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb
index 9731e0bba7..f7a0a5e736 100644
--- a/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb
+++ b/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb
@@ -1,17 +1,7 @@
-SUMMARY = "An abstract syntax tree for Python with inference support."
-HOMEPAGE = "https://pypi.python.org/pypi/astroid"
-SECTION = "devel/python"
-LICENSE = "LGPL"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+inherit setuptools
+require python-astroid.inc
-SRC_URI[md5sum] = "6f65e4ea8290ec032320460905afb828"
-SRC_URI[sha256sum] = "492c2a2044adbf6a84a671b7522e9295ad2f6a7c781b899014308db25312dd35"
-
-inherit setuptools pypi
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-distutils \
- ${PYTHON_PN}-lazy-object-proxy \
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-wrapt \
-"
+RDEPENDS_${PN}_class-target += "${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-importlib \
+ ${PYTHON_PN}-singledispatch \
+ "