aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-gevent.inc
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-07 15:40:33 +0100
committerKhem Raj <raj.khem@gmail.com>2019-02-07 10:06:39 -0800
commit20e56eb002d0906ad72106f8ff1a821f3771c478 (patch)
treeda9f767557691464e42442d9bfc7690924c96a42 /meta-python/recipes-devtools/python/python-gevent.inc
parent2e0fd78621b05acb6df58adf910373a8814b70a1 (diff)
downloadmeta-openembedded-contrib-20e56eb002d0906ad72106f8ff1a821f3771c478.tar.gz
python3-gevent: update to 1.4.0
This fixes build issues with Python 3.7. License-Update: added BSD license for one of the source files Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-gevent.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-gevent.inc10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent.inc b/meta-python/recipes-devtools/python/python-gevent.inc
index 13513f2192..bc89d104af 100644
--- a/meta-python/recipes-devtools/python/python-gevent.inc
+++ b/meta-python/recipes-devtools/python/python-gevent.inc
@@ -4,8 +4,9 @@ a high-level synchronous API on top of the libevent event loop."
HOMEPAGE = "http://www.gevent.org"
LICENSE = "MIT & Python-2.0 & BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
- file://NOTICE;md5=5966cd2c6582656d28ab3c33da3860f8 \
- file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347"
+ file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
+ file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
+ "
DEPENDS += "libevent"
DEPENDS += "${PYTHON_PN}-greenlet"
RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \
@@ -17,10 +18,11 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:"
SRC_URI_append = " \
file://libev-conf.patch;patch=1;pnum=1 \
+ file://0002-setup.py-do-not-query-for-include-dir.patch \
"
-SRC_URI[md5sum] = "7f0baf355384fe5ff2ecf66853422554"
-SRC_URI[sha256sum] = "4791c8ae9c57d6f153354736e1ccab1e2baf6c8d9ae5a77a9ac90f41e2966b2d"
+SRC_URI[md5sum] = "6b9dd98917061803d9158e5258b8f412"
+SRC_URI[sha256sum] = "1eb7fa3b9bd9174dfe9c3b59b7a09b768ecd496debfc4976a9530a3e15c990d1"
# The python-gevent has no autoreconf ability
# and the logic for detecting a cross compile is flawed