aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-17 13:25:40 -0500
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commit456a16a2a86ecfd36d40a8d014d4a45631b90f59 (patch)
treefb6a72e0ab6e9f7dd2a12be6f78ecf2f94dc2694 /meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
parentc37eecafb8a4dd0d2a6822f6d43dfd79944ca0e8 (diff)
downloadmeta-openembedded-contrib-456a16a2a86ecfd36d40a8d014d4a45631b90f59.tar.gz
python-grpcio: update to version 1.7.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
new file mode 100644
index 0000000000..3ca7d5366b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Google gRPC"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+DEPENDS = "python-protobuf"
+
+SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
+ "
+RDEPENDS_${PN} = "python-enum34 \
+ python-futures \
+ python-protobuf \
+ python-setuptools \
+ python-six \
+"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "b564632793132fd35cdff984d6b309b0"
+SRC_URI[sha256sum] = "6662af1f07cf7a3d171a7f56afc2cfeff262a5f2c52d15ae5ea581d0c367aea8"
+
+# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native"