aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-idna_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-23 12:13:47 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:33:06 +0100
commit06f04adf4b6572f79839240bdd6e0b0f389bbc08 (patch)
treee03e40b6d324090e3313c6e224f2b3c54c08602b /meta-python/recipes-devtools/python/python-idna_git.bb
parent2463e39c449cb3431e28a2a1ed5c31f778bf47bc (diff)
downloadmeta-openembedded-contrib-06f04adf4b6572f79839240bdd6e0b0f389bbc08.tar.gz
python-cryptography, python-cryptography-vectors: uprev
Pick up many fixes and enhancements made since 0.8.1 was released. See: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst The uprev requires an uprev of pyasn1 and also pulls in two new packages idna and ipaddress. The idna software has 3 licenses, one of which is the 'Unicode' license: http://www.unicode.org/copyright.html Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-idna_git.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-idna_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-idna_git.bb b/meta-python/recipes-devtools/python/python-idna_git.bb
new file mode 100644
index 0000000000..f5ce658cb8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-idna_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Internationalised Domain Names in Applications"
+HOMEPAGE = "https://github.com/kjd/idna"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c61e6ec7ab3da6b340d8d3a89c964ef2"
+
+PV = "2.0"
+SRCREV = "bb6e94c5b5525684d8ca010bf8ab42480c319e0a"
+
+SRCNAME = "idna"
+SRC_URI = "git://github.com/kjd/${SRCNAME}.git"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools
+
+DEPENDS += " \
+ python-pip \
+ "
+
+RDEPENDS_${PN} += " \
+ "