aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit9d9a616a392deeb06bf7458902281c9bfeb7f5b6 (patch)
treedccc15079aa4f39de3266c838415202ada4a4060 /meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
parentb62ae60f869b83721757a2f5316cdc26c1030af3 (diff)
downloadmeta-openembedded-contrib-9d9a616a392deeb06bf7458902281c9bfeb7f5b6.tar.gz
Update python recipes to use the common pypi package
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
index 504bb99088..bb5a5ff409 100644
--- a/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
+++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
@@ -1,21 +1,12 @@
SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
-SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
-SRCNAME = "jsonpatch"
-
-SRC_URI = " \
- https://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
-"
-
-inherit setuptools
+inherit pypi setuptools
SRC_URI[md5sum] = "76ae3183db5f2a8f85dd7705e9b6f278"
SRC_URI[sha256sum] = "2e1eb457f9c8dd5dae837ca93c0fe5bd2522c9d44b9b380fb1aab2ab4dec04b1"
RDEPENDS_${PN} += "python-re python-json python-jsonpointer"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-